Closed Bug 1845376 Opened 11 months ago Closed 10 months ago

With "Just mark it as deleted", after dragging a message from inbox to a folder, the selection jumps over to the 2nd message

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115+ fixed, thunderbird117 affected)

RESOLVED FIXED
118 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 + fixed
thunderbird117 --- affected

People

(Reporter: csm, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

(Keywords: regression, triaged, Whiteboard: [Supernova3p])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/115.0.0.0 Safari/537.36

Steps to reproduce:

In inbox, after moving a message from the list of emails by dragging to a folder, the highlighted selection jumps over the next message to the second one.

115.0.1

Actual results:

Jumps two messages rather than to next one.

Expected results:

Should jump to next message.

Hmm..... looks ok with Gmail inbox connections. Has the issue with inbox on Comcast IMAP. Was not an issue with earlier Thunderbird versions, started with the 115 update.

Please test if this happens with 115.1.0 in a couple days

Blocks: sn-msglist
Component: Untriaged → Folder and Message Lists
Flags: needinfo?(csm)
Keywords: regression
Whiteboard: [Supernova3p]

Confirmed: Daily 118.0a1 (2023-08-01) (64-bit); MacOS 13.3.1 (a)

IMAP mark-as-deleted. Local dovecot IMAP server. Nothing in error console.

Happens for me when moving via menu folder selection, no need to drag/drop.

(assuming this also happens on beta)

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(csm) → needinfo?(alessandro)

(In reply to Wayne Mery (:wsmwk) from comment #2)

Please test if this happens with 115.1.0 in a couple days

Wayne, still happening with the 115.1.0 update.

Thanks, Carl

(In reply to csm from comment #1)

Hmm..... looks ok with Gmail inbox connections. Has the issue with inbox on Comcast IMAP. Was not an issue with earlier Thunderbird versions, started with the 115 update.

I can't seem to reproduce this with Gmail or Fastmail, both IMAP.
Do you have any information on what might be different in your Comcast IMAP? Or maybe that account has some specific settings that differ from the other accounts?

Flags: needinfo?(alessandro)

Ah! I was able to reproduce it!
Changing the delete message to "Just mark it as deleted" causes the issue.

Magnus, could you take a look at this?

Severity: -- → S3
Flags: needinfo?(mkmelin+mozilla)
Keywords: triaged
Priority: -- → P2
Summary: After dragging a message from inbox to a folder, the selection highlighted jumps over to the 2nd message → With "Just mark it as deleted", after dragging a message from inbox to a folder, the selection jumps over to the 2nd message

Investigating

Assignee: nobody → mkmelin+mozilla
Flags: needinfo?(mkmelin+mozilla)
Target Milestone: --- → 118 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/605a9a33202a
Select correct message after move for imap mark-as-deleted. r=darktrojan

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Comment on attachment 9349265 [details]
Bug 1845376 - Select correct message after move for imap mark-as-deleted. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): supernova
User impact if declined: bad advance after moving, with imap mark-as-deleted
Testing completed (on c-c, etc.): c-c, beta
Risk to taking this patch (and alternatives if risky): safe

Attachment #9349265 - Flags: approval-comm-esr115?

Comment on attachment 9349265 [details]
Bug 1845376 - Select correct message after move for imap mark-as-deleted. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9349265 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: