Font doesnt reflow properly in tables and I think this might be due to CSS.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: rnhurt, Assigned: kmcclusk)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130

The rant section of MegaTokyo has always given me some issues, but I thought
1.2.1 would fix it.  It looks like it is caused by the larger than default font
in use.  I am running 800x600 on my Rec B iMac with a default font of Times 13
point.

Reproducible: Always

Steps to Reproduce:
1.Load http://megatokyo.com
2.Scroll down to the NEWSBOX section (directly under the comic)
3.Notice how the text overflows the table and is completely unreadable in some
places.

Actual Results:  
The text does not flow properly in the tables.  It overlaps and is very hard to
read in places.

Expected Results:  
The text should flow inside the table.
Created attachment 108835 [details]
screenshot, linux build 2002-12-07-22 trunk

I see about the same thing with a linux 1.2.1 build...	I assume that you're
seeing something rather different?
(Reporter)

Comment 2

16 years ago
Created attachment 108968 [details]
Screenshot of the error on my Macintosh

No, I have attached a screenshot of what it looks like on my iMac.  This same
page, using 1.2.1 on Windows 2000 looks fine just like your Linux shot.  This
seems to be restricted to Macintosh OS 9.x.
Looks like broken font measurement.
Assignee: font → kmcclusk
Component: Layout: Fonts and Text → GFX Compositor

Comment 4

16 years ago
This might depend on the font being used. It looks fine in my 11/14 Macho build.
Created attachment 109026 [details]
Screenshot of proper rendering in 2002120903/MacOS9.1

Here's what I see in this morning's trunk build on my Macintosh (OS9.1).  I
fiddled with Text Zoom and still didn't see the overlap.  My default fonts are
Times New Roman, Helvetica, Apple Chancery, Gadget, and Courier, with the
non-monospace at 16 pixels and the monosapce at 13 pixels, with the 96dpi
setting.
(Reporter)

Comment 6

16 years ago
I set my fonts to the same setting and it is still wrong for me (OS9.2.2).  I
don't know if it makes a difference, but I am using the Pinball theme (it
shouldn't but sometimes you can't rule out anything).
(Reporter)

Comment 7

16 years ago
I just changed to Modern theme and it is still broken.  I will download the
nightly and see if that fixes it.
(Reporter)

Comment 8

16 years ago
According to Megatokyo, there were blatent errors with the HTML that caused the
problems I was seeing.  I still think something was wrong because I could see if
fine in W2K but not OS9.  Oh well.

Comment 9

16 years ago
Richard, is this happening anymore?
(Reporter)

Comment 10

16 years ago
No, not anymore.  I am still on Mac OS 9.2.2 but I upgraded to Mozilla 1.3b and
Megatokyo fixed thier HTML.  So, I guess we wont know if it is truly fixed or
not.  For now I guess we can close it.

Thanx! 
  Richard

Comment 11

16 years ago
marking WFM per reporters last comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.