mail index corrupt after receipt of 2 Windows .lnk link files and a mail w/ large attachments

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
major
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Wolfgang Loebnitz, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

After startup of Mozilla mail the programm started popping messages from our
network. It started w/ 3 emails sent by MS Outlook Express. The beginning 2
emails contained an MS Windows .lnk link file. The 3rd email contained 17 .jpg
5MB in total. While download was in progress I clicked onto the latter email and
saw those jpegs indicated in the attachmentlist (content pane). Since that mail
was still downoading I read an older mail.
After completion of mail download (5 total) I clicked the newest message and
recognized the content displayed didn't match the indicated subject in the list
of emails. The eMail w/ those jpegs did not indicate attachments anymore but the
body contained html mixed w/ base64 encoded blocks. 
A subfolder indicated 2 new mails but none was visible/reachable in the index.

My unix system indicated the receipt of 10 emails. The content firstly mentioned
above belonged to an email not indicated in the mozilla list. None of the
content of emails received after receipt of the 3 outlook mails did match the
list of emails (subject). After deleting the Outlook mails, new mail can be
received properly. Old mail is also stored properly. 

Reproducible: Didn't try

Steps to Reproduce:
on request I will be able to forward any of the suspected problematic emails


Expected Results:  
fix Mozilla mail bug, produce repair tool for mailbox
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

15 years ago
do you download your mail using pop3? It sounds like the basic problem is that
you were clicking around reading new messages while messages were still getting
downloaded. Those problems were supposed to have been fixed, but it sounds like
they weren't.
Component: Mail Database → Mail Back End
(Assignee)

Comment 2

14 years ago
no response, marking wfm.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.