Painfully slow attachment processing after pressing SEND button + many I/O

VERIFIED DUPLICATE of bug 180516

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 180516
16 years ago
10 years ago

People

(Reporter: Slawomir Oczkowski, Assigned: Scott MacGregor)

Tracking

({perf})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I COMPOSE new e-mail. I attach a file (e.g. a document) of size ~ 1 MB. On my
PIII 1.2 GHz computer it takes 70 second ! (35 sec encoding ! (this is very
slow), 10 secs pushing the message to the SMTP server and rest is just placing
into Sent folder. 
IMPORTANT:
This problem does not exist in previous versions: 1.1 or 1.2b (I haven't used 1.2)
The PC then makes a lot of very short I/O operations and just moves a lot disk
arm heads (This is how it lookes like).

Reproducible: Always

Steps to Reproduce:
1. Compose an e-mail (feel in the To: and Subject: (not needed)
2. Attach a file (size not important, but when > 1 MB you can loose your patiens
seeing the defference
3. Press SEND button and wait :), wait, wait ...
4. Now try the above procedure on e.g. v. 1.1 which I am sure was pretty much faster
Actual Results:  
it take to long and the PC/Laptop make a lot of short I/O ops.

Expected Results:  
Turn it back in the source code like it was in Mozilla 1.1 version (?) (which I
resigned to use because of poor certificates management mechanizms)

-

Updated

16 years ago
Keywords: perf
(Reporter)

Comment 1

16 years ago
When I tried to FORWARD an e-mail (with 1 MB attachment) which is in my INBOX
the same performance problem exists.

Comment 2

16 years ago
You may want to check out the 1.3 builds.  It looks like bug 182263 fixed some
disk I/O issues.  See also bug 183991.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 180516 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified
Status: RESOLVED → VERIFIED
QA Contact: yulian → esther

Comment 5

16 years ago
Just a me too. With version 1.2.1 on Linux and only when the CPU is
@ 100% by another application, sending a large mail takes AGES!!

The fact that it's OK when there are no other processes to schedule,
suggests that mozilla is making os calls VERY OFTEN. Is is doing
1 byte writes to the network, or 1 byte reads from the disk?
Seems like it anyway.

Is 161829 a dup?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.