window.status text is global for all tabs. update in one tab makes it the status text for all

VERIFIED DUPLICATE of bug 104532

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 104532
16 years ago
10 years ago

People

(Reporter: Konstantin Vainer, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021128
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021128

when setting window.defaultStatus= or window.status= inside one tab, the text in
window status sticks for every tab in same window, which is confusing....

Reproducible: Always

Steps to Reproduce:
1. open two or more tabs in single window
2. load some url that changes window.defaultStatus in 1st tab
3. load other url that changes window.defaultStatus in 2nd tab
4. switch a couple of times between the tabs, take a look at the status text...

Actual Results:  
the last text used by window.defaultStatus (no matter in what tab) becomes the
defaultStatus text for all the tabs in the window...

Expected Results:  
every tab should have its own text in status line ...
no matter what other tabs change for themselves

i believe tabbed browsing is just the convenient way to put several _windows_
together inside one container. that means that these windows should still have
separate properties - like window.status ... in this example.
i did not check, but i assume that if this behaves the way i described, then
probably "window.close()" will close all the container window instead of just
the tab...

This behavior is confusing.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.