Closed Bug 1846880 Opened 1 year ago Closed 11 months ago

Quick Filter: Persist "keep filters applied" selection on restart

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr115 fixed)

RESOLVED FIXED
118 Branch
Tracking Status
thunderbird_esr115 --- fixed

People

(Reporter: elijmitchell, Assigned: elijmitchell)

References

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1833257 +++

Description

On application restart, the user's selection for "Keep filters applied" in Quick Filter settings should be remembered.

102

  • Current: On restart, user selected button state is retained
  • Desired change: Keep current functionality

115

  • Current: On restart, button state is reset to not enabled
  • Desired change: On restart, remember the user’s selection and set the button to that state

This returns functionality in 115 to what is the current functionality in 102.


Original report from Thomas D. :thomas8) from bug 18233257 comment #0)
Seen on 115.0a1 (2023-05-15) (64-bit), Win10.

From post on TB-Beta, Can the "keep filters applied" toggle be made sticky?

TB 102 used to persist the status of quick filter buttons across TB restart, but Daily doesn't do that any more.

STR

  • Switch on Keep filters applied when changing folders and Unread quick filter.
  • Restart TB
  • Observe status of the filter buttons

Actual

  • filter button status not persisted

Expected

  • Should probably just persist filter button status as in 102.
  • Otherwise persisting filter states should probably be available as an option.
  • It's worth noting that the filter text is not persisted, probably by design.
  • The rationale here is that the buttons act like view filters, which users may want to have applied always depending on their workflows. Which is different from filter text, which targets specific messages.
Priority: -- → P2
  • Set variable on button state change
Depends on: 1849221
  • On application restart, display user's setting for sticky.

Depends on D186494

Attachment #9349511 - Attachment description: Bug 1846880: Show Quick Filter keep filters applied selection. r=#thunderbird-front-end-reviewers → Bug 1846880 - Show Quick Filter keep filters applied selection. r=#thunderbird-front-end-reviewers
Attachment #9349511 - Attachment description: Bug 1846880 - Show Quick Filter keep filters applied selection. r=#thunderbird-front-end-reviewers → Bug 1846880 - Show Quick Filter keep filters applied selection. r=freaktechnik
Attachment #9347738 - Attachment is obsolete: true
Target Milestone: --- → 118 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/822f00b1219f
Show Quick Filter keep filters applied selection. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9349511 [details]
Bug 1846880 - Show Quick Filter keep filters applied selection. r=freaktechnik

[Approval Request Comment]
Regression caused by (bug #): Changes from 102 to 115
User impact if declined: Many users want the ability to persist quick filter settings on reload as they could do in 102.
Testing completed (on c-c, etc.): Tested locally, try run, and in c-c
Risk to taking this patch (and alternatives if risky): Low

Attachment #9349511 - Flags: approval-comm-esr115?
Attachment #9349511 - Flags: approval-comm-beta?

Comment on attachment 9349511 [details]
Bug 1846880 - Show Quick Filter keep filters applied selection. r=freaktechnik

[Triage Comment]
Approved for beta

Attachment #9349511 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9349511 [details]
Bug 1846880 - Show Quick Filter keep filters applied selection. r=freaktechnik

[Triage Comment]
Approved for esr115

Attachment #9349511 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: