Closed Bug 1847066 Opened 10 months ago Closed 9 months ago

Firefox hangs randomly when doing a Google search

Categories

(Core :: Networking, defect)

Firefox 116
defect

Tracking

()

VERIFIED FIXED
118 Branch
Tracking Status
relnote-firefox --- 116+
firefox-esr102 --- unaffected
firefox-esr115 117+ fixed
firefox116 + fixed
firefox117 + fixed
firefox118 + fixed

People

(Reporter: add2718, Assigned: jesup)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [stockwell disabled])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/116.0

Steps to reproduce:

Enter something to search for in the taskbar

Actual results:

About half the time, Firefox will just hang instead of loading the google search.

Expected results:

Usually in the past it goes immediately to the Google search page.

Hello, thank you for the bug report!
Unfortunately I could not reproduce your issue. Would you be so kind as to answer a few questions so we can investigate this further?

Moving the Component to 'Address Bar'. Please change if there's a better fit, thank you.

Flags: needinfo?(add2718)
Component: Untriaged → Address Bar

I confirm with user, add2718, that firefox waits a long time before fully loading pages on google, google voice and worldstar.com.

When I go to any of these sites, I have to wait 30 - 60 secs before these pages load fully.

The latest firefox version, 116.0.2, is the culprit. Before the latest update, these sites loaded quickly with no hang time whatsoever.

Mozilla needs to fix this major bug fast!

I confirm with user, add2718, that firefox waits a long time before fully loading pages on google, google voice and worldstar.com.

When I go to any of these sites, I have to wait 30 - 60 secs before these pages load fully. This happens randomly about half of the time. The half of the time the sites load quickly.

The latest firefox version, 116.0.2, is the culprit. Before this latest update, these sites loaded quickly with no hang time whatsoever.

Mozilla needs to fix this major bug fast!

(In reply to sil from comment #3)

I confirm with user, add2718, that firefox waits a long time before fully loading pages on google, google voice and worldstar.com.

When I go to any of these sites, I have to wait 30 - 60 secs before these pages load fully. This happens randomly about half of the time. The half of the time the sites load quickly.

The latest firefox version, 116.0.2, is the culprit. Before this latest update, these sites loaded quickly with no hang time whatsoever.

Mozilla needs to fix this major bug fast!

It started for me with either 116.0.0 or 116.0.1 (I think 116.0.0)

Flags: needinfo?(add2718)

(In reply to add2718 from comment #4)

(In reply to sil from comment #3)

I confirm with user, add2718, that firefox waits a long time before fully loading pages on google, google voice and worldstar.com.

When I go to any of these sites, I have to wait 30 - 60 secs before these pages load fully. This happens randomly about half of the time. The half of the time the sites load quickly.

The latest firefox version, 116.0.2, is the culprit. Before this latest update, these sites loaded quickly with no hang time whatsoever.

Mozilla needs to fix this major bug fast!

It started for me with either 116.0.0 or 116.0.1 (I think 116.0.0)

Nah it really started in 116.02

I was going crazy with this, uninstallet firefox, extension etc, then searched on google and found this, btw i have the same issue, on google if i simply search or copy n paste text it will hang 99% of the time. I have a powerful machine (13900k, 4090fe, 32gb 7200mt/s).
I love firefox but i always have problems, it's kinda infuriating but i don't want to use chromium browsers, i don't like them.
Anyway, i recorded the bug:

https://streamable.com/wmdp2f

I am on windows 11 btw and firefox 106.2.

(In reply to GGiuliano93 from comment #6)

I was going crazy with this, uninstallet firefox, extension etc, then searched on google and found this, btw i have the same issue, on google if i simply search or copy n paste text it will hang 99% of the time. I have a powerful machine (13900k, 4090fe, 32gb 7200mt/s).
I love firefox but i always have problems, it's kinda infuriating but i don't want to use chromium browsers, i don't like them.
Anyway, i recorded the bug:

https://streamable.com/wmdp2f

I am on windows 11 btw and firefox 106.2.

Exactly! Its no surprise I'm not the only one complaining about this issue. Obviously its up to mozilla to fix this huge bug soon. Its annoying as fuck to say the least.

Update, it happened also on amazon when logging in

please attach a txt log from the about:support page.

Component: Address Bar → Networking
Product: Firefox → Core
Summary: Firefox hangs randomly when doing a Google search in the taskbar → Firefox hangs randomly when doing a Google search
Attached file About support page

Hope it's ok

This is the readable elaborated version

(In reply to GGiuliano93 from comment #11)

This is the readable elaborated version

Thank you. Does the situation improve if in about:config you reset the value of network.http.speculative-parallel-limit to the default value 6?

Flags: needinfo?(ggiulian0)

(In reply to Marco Bonardo [:mak] (away 11-21 Aug) from comment #13)

(In reply to GGiuliano93 from comment #11)

This is the readable elaborated version

Thank you. Does the situation improve if in about:config you reset the value of network.http.speculative-parallel-limit to the default value 6?

it does the same

Flags: needinfo?(ggiulian0)

Hi, can you try uninstalling the addon uBlock Origin?

Flags: needinfo?(ggiulian0)
Flags: needinfo?(add2718)

If anyone who can reproduce this bug could capture network logs, that would be very helpful.

Go to about:logging, press Start Logging
Then reproduce the bug, i.e. google search stuck
When Firefox is stalled, go back to the about:logging tab and press Stop Logging
This will open a new tab with a performance profile that can be shared via the "Upload Local Profile" button.
If possible, please check as many of the checkboxes for included data.

When you have the link to the profile, https://share.firefox.dev/XYZetc, then you can email it to necko@mozilla.com

(In reply to Marco Bonardo [:mak] (away 11-21 Aug) from comment #13)

(In reply to GGiuliano93 from comment #11)

This is the readable elaborated version

Thank you. Does the situation improve if in about:config you reset the value of network.http.speculative-parallel-limit to the default value 6?

I think this may have fixed the issue. The value was set at 0 for whatever reason on both my computers, changing it to 6 seems to definitely have helped.
I don't think UBlock Origin mattered.

Flags: needinfo?(add2718)

I don't think UBlock Origin mattered.

uBlock Origin usually sets that pref to 0, so it can impact the behaviour (if this is in fact caused by that pref).
If you can still reproduce this bug, could you set the pref back and see comment 16 regarding capturing some logs? Thanks!

Flags: needinfo?(add2718)

(In reply to Andrew Creskey [:acreskey] from comment #16)

If anyone who can reproduce this bug could capture network logs, that would be very helpful.

Go to about:logging, press Start Logging
Then reproduce the bug, i.e. google search stuck
When Firefox is stalled, go back to the about:logging tab and press Stop Logging
This will open a new tab with a performance profile that can be shared via the "Upload Local Profile" button.
If possible, please check as many of the checkboxes for included data.

When you have the link to the profile, https://share.firefox.dev/XYZetc, then you can email it to necko@mozilla.com

https://share.firefox.dev/450Er7H here it is

Flags: needinfo?(ggiulian0)

(In reply to Andrew Creskey [:acreskey] from comment #15)

Hi, can you try uninstalling the addon uBlock Origin?

I uninstalled it but it still happens

Thank you so much for the profile, Giuliano.
It looks like you have Kaspersky Antivirus running which may be interfering with the requests.
Can you try disabling the antivirus software to see if you still see the problem?

Flags: needinfo?(ggiulian0)

(In reply to Andrew Creskey [:acreskey] from comment #21)

It looks like you have Kaspersky Antivirus running which may be interfering with the requests.

Its NOT the antivirus.

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

(In reply to Andrew Creskey [:acreskey] from comment #23)

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

(In reply to Andrew Creskey [:acreskey] from comment #21)

Thank you so much for the profile, Giuliano.
It looks like you have Kaspersky Antivirus running which may be interfering with the requests.
Can you try disabling the antivirus software to see if you still see the problem?

I tried with kaspersky disabled and it still does this

Flags: needinfo?(ggiulian0)

(In reply to Andrew Creskey [:acreskey] from comment #23)

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

If i disable the antivirus and do another profile it will will be useful or it will still show in the report?

Let me know!

(In reply to GGiuliano93 from comment #25)

(In reply to Andrew Creskey [:acreskey] from comment #23)

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

If i disable the antivirus and do another profile it will will be useful or it will still show in the report?

Let me know!

Thanks for ruling out kaspersky.

Yes, another profile, preferably without antivirus would be helpful.

(In reply to Andrew Creskey [:acreskey] from comment #26)

(In reply to GGiuliano93 from comment #25)

(In reply to Andrew Creskey [:acreskey] from comment #23)

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

If i disable the antivirus and do another profile it will will be useful or it will still show in the report?

Let me know!

Thanks for ruling out kaspersky.

Yes, another profile, preferably without antivirus would be helpful.

https://share.firefox.dev/3KAsYU9

here it's the test with kaspersky disabled

(In reply to Andrew Creskey [:acreskey] from comment #26)

(In reply to GGiuliano93 from comment #25)

(In reply to Andrew Creskey [:acreskey] from comment #23)

It's not clear that the profile from comment 19 is capturing the problem.
I don't see the google request being delayed and the tab is responsive throughout.

Any additional profiles would be helpful.

If i disable the antivirus and do another profile it will will be useful or it will still show in the report?

Let me know!

Thanks for ruling out kaspersky.

Yes, another profile, preferably without antivirus would be helpful.

I created a new profile and firefox exhibits the same phenomenon. The same thing happens on a different computer.

Hi,

Kaspersky injection still seems to be happening.
Could you disable it via these instructions https://forum.kaspersky.com/topic/what-is-kaspersky-labscom-ffkisv2scrkaspersky-labscom-21484/?do=findComment&comment=92639 in Kaspersky and try again?

In the profiles you've shared, I don't see any network requests hanging.
Make sure to start logging before you do the search.

Flags: needinfo?(si.leebo)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #29)

Hi,

Kaspersky injection still seems to be happening.
Could you disable it via these instructions https://forum.kaspersky.com/topic/what-is-kaspersky-labscom-ffkisv2scrkaspersky-labscom-21484/?do=findComment&comment=92639 in Kaspersky and try again?

In the profiles you've shared, I don't see any network requests hanging.
Make sure to start logging before you do the search.

I can't find that option, i have the new kaspersky plus, btw it did happen even when i haven't installed and windows was using defender.
Btw i downloaded firefox developer 117.0b6 and it still happens, it's not like an network request hanging, it's the tab and page that freezes, idk...

Nevermind, i uninstalled kaspersky plus then firefox, then i installed firefox again with a fresh install and it's not happening anymore... so it's kaspersky the issue :s

@sil and @add2718 - can you provide your about:support info? Do you have Kaspersky? If so, can you uninstall it and try again?

And if either of you can get a profile, preferably by going to about:logging and starting a network profile from there, that would be great. The profile can be directly shared, or it can be downloaded and mailed to necko@mozilla.com, or put on a site like box.com and shared privately with necko@mozilla.com or with one of our engineers.

(In reply to GGiuliano93 from comment #31)

Nevermind, i uninstalled kaspersky plus then firefox, then i installed firefox again with a fresh install and it's not happening anymore... so it's kaspersky the issue :s

I dont have kaspersky and I still have this issue

Flags: needinfo?(si.leebo)

I have the my ready for you devs to view. But I dont understand the instructions on how to upload to the right people here.

When you have the link to the profile, https://share.firefox.dev/XYZetc, then you can email it to necko@mozilla.com

I dont understand how to submit to: https://share.firefox.dev/XYZetc. Please clarify to upload my log.

Also, is my log free from my personal data?

I have my log ready. But I dont understand the instructions on how to upload to the right people here.

When you have the link to the profile, https://share.firefox.dev/XYZetc, then you can email it to necko@mozilla.com

I dont understand how to submit to: https://share.firefox.dev/XYZetc. Please clarify to upload my log.

Also, is my log free from my personal data?

(In reply to sil from comment #35)

I have the my ready for you devs to view. But I dont understand the instructions on how to upload to the right people here.

When you have the link to the profile, https://share.firefox.dev/XYZetc, then you can email it to necko@mozilla.com

I dont understand how to submit to: https://share.firefox.dev/XYZetc. Please clarify to upload my log.

Also, is my log free from my personal data?

You go to about:logging (write in the adress bar) then click start record, then go to google and try to replicate the bug, then go to the about:logging tab and click stop. It will open a new tab with all the info for the devs. At the top right of the page you will have an option to upload the generated page to firefox website (named Upload Local Profile). Here you can check what you want to share additionally, like screenshot of the browser etc. After the upload you will get a link and you can post it here or at necko@mozilla.com

For the personal data i don't think it will share anything (i hope)

Update: I reinstalled kaspersky, and the problem was present again, so in my case the problem it's kaspersky.
Then i noticed that kaspersky recommends you to install the extension on firefox (Kasperksy Protection).
I installed the extension and rebooted firefox. Now with the extension installed in firefox the problem it's gone.
So my guess it's there's a bug in kaspersky if you don't have the extension installed.
Hope it helps.

I've been having this issue recently as well. Been following this thread. I run Ubuntu Firefox, and everything was fine until an update or 2 ago, then I started having this. It's hit and miss, sometimes happening, sometimes not. I wasn't able to get it to happen on a fresh profile at first, but just tried again while profiling, and it happened.

Here's the link the upload gave me: https://share.firefox.dev/3QG4pJp

It's from a fresh profile (well, profile was created specifically for this bug a couple days ago). No extensions, no previous data, no altered settings.

I do not have Kaspersky, so it's not just that causing the issue. Looks like some __GI___poll is taking ~90% of the call time. I'd say loading google.com hung for about 20-ish seconds. I did have other things running in another window, however nothing that should have delayed loading google by that long.

Interesting to note, if loading google.com is hanging, but you attempt to hit it again in the same tab (just as simply as clicking address bar and hitting Enter), it loads immediately

Same bug but on youtube!! On youtube home I click a video then try to go back to home, the page is blank. This is intermittent and has been experienced a few times now.

(In reply to Kyle M from comment #39)

I've been having this issue recently as well. Been following this thread. I run Ubuntu Firefox, and everything was fine until an update or 2 ago, then I started having this. It's hit and miss, sometimes happening, sometimes not. I wasn't able to get it to happen on a fresh profile at first, but just tried again while profiling, and it happened.

Here's the link the upload gave me: https://share.firefox.dev/3QG4pJp

It's from a fresh profile (well, profile was created specifically for this bug a couple days ago). No extensions, no previous data, no altered settings.

I do not have Kaspersky, so it's not just that causing the issue. Looks like some __GI___poll is taking ~90% of the call time. I'd say loading google.com hung for about 20-ish seconds. I did have other things running in another window, however nothing that should have delayed loading google by that long.

Observation from profile: The main request to https://google.com seems to be blocked on a network request to the safebrowsing api that started a bit earlier. (See networking tab in parent process)

(In reply to Manuel Bucher [:manuel] from comment #42)

Observation from profile: The main request to https://google.com seems to be blocked on a network request to the safebrowsing api that started a bit earlier. (See networking tab in parent process)

I don't know why that would take so long. Not sure if there's some change to Firefox that could be slowing that down. My network speed is definitely not that bad (it's generally around 200-300 Megabits/second, so a 9MB request should resolved in less than a second effectively). It definitely wasn't an issue prior to the most recent major version. I can attempt to get it to happen again with another profiler, to see if it's the same issue each time it seems to hang.

The safe browsing request is 9.78MB - so it might just be that it takes a while to download it.

Looking at the log lines related to that request:

3.552s (nsHttp) nsHttpChannel::AsyncOpen [this=7f3339323100] <--- channel is opened
3.647s (nsHttp) nsHttpChannel::OnLookupComplete [this=7f3339323100] prefetch complete, refresh requested: success status[0x0] <-- DNS completed
5.193s (nsHttp) nsHttpChannel::OnStartRequest [this=7f3339323100 request=7f3339bc2e80 status=0] <-- incoming headers are parsed
5.194s (nsHttp) nsHttpChannel::OnDataAvailable [this=7f3339323100 request=7f3339bc2e80 offset=0 count=32768] <--- first bytes of the response body
...
16.162s (nsHttp) nsHttpChannel::OnDataAvailable [this=7f3339323100 request=7f3339bc2e80 offset=10255474 count=5565] <-- last bytes of the response body

Now we have to figure out if actually waiting for the safebrowsing download is what's supposed to happen.

Why cant you simply compare the latest firefox version with the previous version and find the issue?

(In reply to sil from comment #45)

Why cant you simply compare the latest firefox version with the previous version and find the issue?

There are a lot of changes between Firefox versions. :)

Good news, though -- I'm able to reproduce this bug occasionally [--> confirming] and, with guidance from Kershaw on the networking team, we're pretty sure this was caused by the pref-flip in bug 1816677.

Could folks who hit this bug try setting network.http.http3.retry_different_ip_family to false and see if that fixes the issue for you? (Might require a browser restart to take effect.) So far, that seems to have fixed the issue for me.

Status: UNCONFIRMED → NEW
Ever confirmed: true

(Tentatively flagging as regressed-by bug 1816677, per discussion with kershaw.)

Keywords: regression
Regressed by: 1816677

Set release status flags based on info from the regressing bug 1816677

Assignee: nobody → rjesup
Duplicate of this bug: 1848753

(In reply to Daniel Holbert [:dholbert] from comment #46)

(In reply to sil from comment #45)

Why cant you simply compare the latest firefox version with the previous version and find the issue?

There are a lot of changes between Firefox versions. :)

Good news, though -- I'm able to reproduce this bug occasionally [--> confirming] and, with guidance from Kershaw on the networking team, we're pretty sure this was caused by the pref-flip in bug 1816677.

Could folks who hit this bug try setting network.http.http3.retry_different_ip_family to false and see if that fixes the issue for you? (Might require a browser restart to take effect.) So far, that seems to have fixed the issue for me.

I can tentatively confirm that changing the http3.retry option, listed above, to false seems to fix the issue. I'm running the latest Firefox, in permanent private mode, with uBlock Origin, and no antivirus. Will report back if outcome changes.

Comment on attachment 9348956 [details]
Bug 1847066: flip back the network.http.http3.retry_different_ip_family pref r=#necko-reviewers!

Beta/Release Uplift Approval Request

  • User impact if declined: random 30s hangs on H3 connections
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Going back to previous behavior, just return failure instead of trying switching IPV4/IPV6
  • String changes made/needed: none
  • Is Android affected?: Yes

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Regressor was uplifted to ESR115
  • User impact if declined: random 30s hangs on H3
  • Fix Landed on Version: 118
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Going back to previous behavior, just return failure instead of trying switching IPV4/IPV6
Attachment #9348956 - Flags: approval-mozilla-release?
Attachment #9348956 - Flags: approval-mozilla-esr115?
Attachment #9348956 - Flags: approval-mozilla-beta?

Comment on attachment 9348956 [details]
Bug 1847066: flip back the network.http.http3.retry_different_ip_family pref r=#necko-reviewers!

Approved for 116.0.3 build 2

Attachment #9348956 - Flags: approval-mozilla-release? → approval-mozilla-release+
Pushed by rjesup@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c01a12560822
flip back the network.http.http3.retry_different_ip_family pref r=necko-reviewers,valentin

Comment on attachment 9348956 [details]
Bug 1847066: flip back the network.http.http3.retry_different_ip_family pref r=#necko-reviewers!

Approved for 117.0b8.

Attachment #9348956 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(rjesup)
Keywords: leave-open
Whiteboard: [stockwell disabled]
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 118 Branch

Comment on attachment 9348956 [details]
Bug 1847066: flip back the network.http.http3.retry_different_ip_family pref r=#necko-reviewers!

Approved for 115.2esr.

Attachment #9348956 - Flags: approval-mozilla-esr115? → approval-mozilla-esr115+
Flags: needinfo?(rjesup)

Closing this as verified fixed as the user hasn't reported back any issue. Verified that network.http.http3.retry_different_ip_family is currently on false on al as I was unable to reproduce the initial issue.

Status: RESOLVED → VERIFIED

Yeah, just adding additional verification: I was previously able to reproduce this (comment 46) and I don't believe I've run into it again since then.

(I think we can clear the needinfo=reporter, too, since it was for a question before we had figured out what was going on here & how to mitigate it.)

Flags: needinfo?(add2718)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: