All users were logged out of Bugzilla on October 13th, 2018

PAC: "ProxyConfig" causes problems.

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: landryd, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Proxy autoconfig does not work. The config file we use is served from apache and
works with Netscaep 4.7x and opera 6.x running on linux. I would very much like
to replace netscape 4.7 with mozilla for our Public access terminals but cannot
if this is not working.

Javascript console says ProxyConfig not defined. Shows error on page 211 (there
are <50 lines in the script). the mimetype applicatio/x-ns-proxy-autoconfig is
defined with mozilla-bin as the helper app.

Reproducible: Always

Steps to Reproduce:
1.Enter the location of the proxy.pac file under Preferences-Advacned-Proxies
aftre clicking the autoproxy radio button
2.Click reload
3.Click OK

Actual Results:  
No sites are blocked. Javascript console messages as above

Expected Results:  
Allowed access to sites defined in PAC file and defaulted to custom page for others.
(Assignee)

Comment 1

16 years ago
reporter: can you share your PAC file with us?  thx!
(Reporter)

Comment 2

16 years ago
Created attachment 108934 [details]
Current proxy pac file
(Assignee)

Comment 3

16 years ago
Comment on attachment 108934 [details]
Current proxy pac file

reporter: can you try removing the 

with (ProxyConfig) {

}

surrounding your FindProxyForURL function.  is suspect that is causing the
problem.  thx!
(Reporter)

Comment 4

16 years ago
Removing the line

with (ProxyConfig) {

}

did take care of the problem. Thanks for your very quick solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

16 years ago
reopening so i can mark this bug INVALID... no patch, not FIXED ;-)
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Assignee)

Comment 6

16 years ago
INVALID per comment #4.

benc: please let me know if we should be supporting "with (ProxyConfig)" in PAC.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Updated

16 years ago
Summary: proxy autoconfig is not working. Netscape 4.x and opera browsers can do proxy autoconfig against the file we use → PAC: "ProxyConfig" causes problems.

Comment 7

16 years ago
what does "with (<STRING>)" mean in Javascript anyhow? It sounds like some kind
of conditional module check...

There are a couple javascript commands that other people added, perhaps as CCK
or MCD feature for Communicator. Bug 91121 is another example, but the with
command used "PreConfig"

I don't think we should support any of that stuff, because nobody ever gave me a
document that tells me what it does. However, if there is a way of making our
parsing more tolerant, that would be nice. The PAC spec says the file should be
just the text of the FindProxyforURL() function, which might be unrealistically
spartan.

You need to log in before you can comment on or make changes to this bug.