gaspricewatch.com - document.all/document.layers sniffing

RESOLVED INVALID

Status

RESOLVED INVALID
16 years ago
4 years ago

People

(Reporter: garth, Assigned: susiew)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021209
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/2002120908

At http://www.GasPriceWatch.com the navigation menu on the left doesn't work as
expected, and I suspect this is due to faulty JS browser sniffing. In IE,
hovering over a link pops up another sub-menu, but in Moz no pop up sub-menu and
the links themselves only point to /default.asp# instead of an alternate page
for the sub-menu.



Reproducible: Always

Steps to Reproduce:
1. Go to http://www.gaspricewatch.com
2. Hover over "US Gas"

Actual Results:  
Nuttin'

Expected Results:  
Show a sub-menu with various links to other pages on the site.

This is the browser sniffing code that's probably to blame:

<script language="JavaScript">
var navVer = parseInt(navigator.appVersion);
if(navVer>=4)if((navigator.appName=='Netscape') &&
(navVer==4))document.write("<"+"script language='JavaScript'
src='nsmenu.js'><\/script\>");
else document.write("<"+"script language='JavaScript' src='iemenu.js'><\/script\>");
</script>

So Moz never even gets to see http://www.gaspricewatch.com/nsmenu.js since it
isn't Netscape 4.x.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: gaspricewatch.com - JS hover menu not working (bad browser sniffing?) → gaspricewatch.com - document.all/document.layers sniffing
(Reporter)

Comment 1

16 years ago
Site has been redesigned, and AFAICT now is fully functional using Moz.

Changing resolution to INVALID since the webmaster fixed it without our help. :)
If this is an incorrect resolution, please feel free to correct it, otherwise
we'll call the matter closed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.