Closed Bug 1848106 Opened 10 months ago Closed 8 months ago

Unable to resize rightmost column

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr115 affected, thunderbird119 affected)

RESOLVED DUPLICATE of bug 1850893
Tracking Status
thunderbird_esr115 --- affected
thunderbird119 --- affected

People

(Reporter: andrixnet, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/114.0

Steps to reproduce:

Updated to TB-115
Columns display and order is not what I need, so I change the default displayed columns and reorder some of them.
Last column is "Size"

Actual results:

Apparently I can resize the width of each column that contains text, which is ok, but I cannot resize the last column (in my case "Size", also text content).

I see that resize control appears on the right side of a column, but the last column is followed by the "columns config button" and no resize control appears.

Furthermore, if I move the "Size" column from last position to somewhere in the middle, I can resize it.
Then I move it back to the rightmost position and the width I set is lost and a very large width is automatically set, which I cannot change.

See Also: → 1848834
See Also: → 1834656

I can confirm this using beta. Can't resize the size column at all.
Still can't resize it when dragged to another location.
Same happens with total column and I assume other counts.
Pretty horrible.

Doesn't seen to happen with some of the "standard" columns like date, from, correpsondents

Blocks: sn-msglist
Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Untriaged → Folder and Message Lists
Ever confirmed: true
Flags: needinfo?(alessandro)
Keywords: regression
Priority: -- → P2

This is a known issue of the new tree view widget.
We were forced to put in place this limitation in order to guarantee stability of the various columns.
If you can't resize a column is because you probably forced the size of all the other columns, so the total table size doesn't have any more "empty" space to handle that column.
You should be able to overcome this issue by shrinking the other columns a bit, in order to regain more space.

Anyway, this is not a blocker and it can be fixed with some wiggling, not optimal and pretty annoying, but we will fix it in the next few months with a good clean up and improvement of the tree view widget in bug 1850893

Status: NEW → RESOLVED
Closed: 8 months ago
Duplicate of bug: 1850893
Flags: needinfo?(alessandro)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.