Closed Bug 1848270 Opened 10 months ago Closed 9 months ago

Url bar can autocomplete to a forgotten site

Categories

(Toolkit :: Data Sanitization, defect)

Firefox 115
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: erwinm, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:109.0) Gecko/20100101 Firefox/115.0

Steps to reproduce:

I encountered a repeated slur on a comics page.

I decided to stop visiting it, I removed it from my history, I used "forget about this site."

Actual results:

It keeps turning up in autocomplete.

I quit, restarted, it still turns up.

Expected results:

It should not turn up in autocomplete.

bug 802298 describes similar behavior, though it stopped.

Component: Untriaged → Address Bar

Possible duplicate of bug 1820503.

Moving this across to the Sync component since it seems that the bug occurs when sync is used.

Component: Address Bar → Sync
See Also: → 1820503

Moving this across to the Sync component since it seems that the bug occurs when sync is used.

I see no evidence sync is implicated here. MarjaE, are you connected to Sync?

Possible duplicate of bug 1820503.

That bug is for our Android browser, so I don't think it's a dupe. While that bug does talk about Sync, I'm not yet sure that this is truly a bug in Sync - the autocomplete bar is complicated, so there are legitimate cases where deleting a bookmark isn't enough to prevent the site from showing up, particularly if there are still visits recorded for the site. In this particular bug, that shouldn't be the case.

Once you can see the site show up in autocomplete, can you again find it in your history (ie, via "Show all History")?

Flags: needinfo?(erwinm)

Yes, I'm on Sync.

It still shows up in my autocomplete.

No, it does not show up in my history.

Flags: needinfo?(erwinm)

I've managed to reproduce this issue while being connected to two different devices using Firefox 116.0.3 and following STR:

  • on first device(Windows 10 x64) sign in with your Firefox account, access https://www.office.com/ multiple times
  • on the second device(macOS 13) sign in with your Firefox account and sync
  • on first device select the option "Forget this site" from the side-menu and sync
  • on the second device sync and then type "off" in the address bar

MarjaE, could you please let us know if you followed same STR when the issue occurred on your side? When did you sync your account? Did you use multiple devices? etc.
If possible please mention the comics website where you first noticed this issue.

Flags: needinfo?(erwinm)

A bit simpler:

  • Type the dddress.

  • "Forget about this site."

  • Type the 1st letters of the address again, on the same machine, same browser, not syncing in-between.

Site was https://existentialcomics.com/

Flags: needinfo?(erwinm)

I'm still not able to reproduce your issue in the latest Nightly 118.0a1 and Firefox 116.0.3 versions on macOS 13 following the STR from Comment 7.
Can you reproduce this issue in Troubleshoot Mode or using a New Profile?
If you are still experiencing this issue, while using your main profile, go to about:support and click on "Copy text to clipboard", then save this information into a txt file and attach it to this ticket.
Also please check if this is reproducible in the latest Nightly 118.0a1 and share the results with us so we can continue investigating. Thanks.

Flags: needinfo?(erwinm)

It occurs in troubleshoot mode in Firefox 115 in MacOS and in troubleshoot mode in Firefox 116 in Fedora. I can't install Nightly. I can't test a new profile, because of bug 1579148.

Flags: needinfo?(erwinm)

I picked "forget about this site" on every device, it is not enough.

Blocks: 1102808

Comment 9 has STR from a single device not connected to sync, so updating the component.

Component: Sync → Data Sanitization
Product: Firefox → Toolkit

I'm still not able to reproduce this issue following the STR from Comment 7 unless I bookmark first the page in question.
So the bookmark shows up as a suggestion and the corresponding URL is autocomplete in the address bar when typing "e".

MarjaE, have you bookmarked the site https://existentialcomics.com/ by any chance?

Flags: needinfo?(erwinm)

I had. But I picked "forget about this site," which should delete the bookmark.

Flags: needinfo?(erwinm)

As far as I know this is the intended behavior here and the bookmarks are not deleted upon using the option "Forget about this site".
Waiting for the developer's opinion also.

(In reply to Ina Popescu, Desktop QA from comment #14)

As far as I know this is the intended behavior here and the bookmarks are not deleted upon using the option "Forget about this site".
Waiting for the developer's opinion also.

Correct! Can we close the bug?

If you don't want the site to show up anymore please clear the bookmark manually. We don't clear bookmarks of passwords due to the risk of accidental data loss.

Thanks for confirming.
Closing this as INVALID.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.