Closed Bug 1848380 Opened 11 months ago Closed 11 months ago

If the search service fails to initialise properly, allow topsites on new tab page to work properly

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED FIXED
118 Branch
Tracking Status
firefox118 --- fixed

People

(Reporter: mcheang, Assigned: mcheang)

References

Details

Attachments

(3 files)

If the search service fails to initialise, we should still allow Firefox to be used.

At the moment, the new tab page doesn't finish starting properly.

Although this should be an extremely rare scenario, that's hopefully only limited to test builds, I think it is worth making sure that at least some of the browser is usable, so that users can still try and find information without needing to resort to switching browsers.

The problem on address bar side was fixed in Bug 1648188

Attachment #9348609 - Attachment description: WIP: Bug 1848380 - Catch Search Service failure on newtab page so topsites can be shown. r=Standard8 → Bug 1848380 - Catch Search Service failure on newtab page so topsites can be shown. r=Standard8,nanj
See Also: → 1849013

Before my patch:
When the search service failed on start-up, the top site tiles on the newtab page did not have any tiles with icons and clicking on the tiles did nothing.

After my patch:
When search service failed on start-up, the top sites tiles are still shown with sponsored tiles, recently visited tiles, and top site tiles.

TRY build for QA testing
This is the build for forcing Search Service to fail on start-up. Builds for linux64, win64, win32, and macosx64.

https://treeherder.mozilla.org/jobs?repo=try&revision=357d4951a22936d30eba572dea2b68432b36299e&selectedTaskRun=E8MQE1DkSNCoOp9mazVMgA.0

Attached video before-topsites-fix.mov
Attached video after-topsites-fix.mov
Flags: qe-verify+
Pushed by mcheang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3f36e7d1699c
Catch Search Service failure on newtab page so topsites can be shown. r=Standard8,nanj
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 118 Branch

The issue is verified fixed using the provided build on macOS and Ubuntu 20.04. Even if the search service fails to initialize, the top sites section works correct and loads the websites.

For Windows 10, whenever I start the build with a new profile, the topsites section is empty, but the browser still functions correctly (navigation works without issues). If I start the build with an existing profile, topsites works without issues (displayed and loading).

There is also another way to 'refresh' the topsites section (by going to the settings wheel on NTP, and expanding the topsites section to 2-4 rows). After that, the topsites section is displayed and works without any issues. Also if the build is restarted, the topsites section is displayed and works.

This was already reproduced by me and Adrian, on separate machines.
@Mandy, Based on the above workaround, do you think it's safe to close as fixed?

Flags: needinfo?(mcheang)

Thank you Cristian. Yes I think it's safe to close as fixed since there's a workaround for windows10.
I'm investigating into why it's failing on windows10 at the moment - I'll file a follow up bug to fix this for windows.

Flags: needinfo?(mcheang)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: