If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"open in new tab" with url and ctrl+enter damages the url

VERIFIED INVALID

Status

()

Firefox
Address Bar
VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: Christian Hansen, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Up to Phoenix 0.3 it was possible to enter a URL into the adress bar and type
ctrl+enter to open it in a new tab (instead in the current one)

Since Phoenix 0.4 the entered URL gets a "www." in front and ".com" at the end,
and opens the resulting URL in a new tab.
e.g. an entered URL "www.orf.at" becomes automatically
"http://www.www.orf.at.com/" which is an invalid URL of course.

Reproducible: Always

Steps to Reproduce:
1. enter an url into the adressbar
2. click ctrl+enter afterwards
3. see the result

Actual Results:  
an error message appears that the entered (and automatically altered) URL is
incorrect

Expected Results:  
open the entered URL in a new Tab
Use Alt+Enter to open the URI in a new tab.
More keyboard shortcuts here: http://texturizer.net/phoenix/keyboard.html

Resolving as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

14 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.