iframe src="c:\" produces "c is not a registered protocol"

RESOLVED DUPLICATE of bug 196120

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 196120
16 years ago
16 years ago

People

(Reporter: Henrik Gemal, Assigned: dougt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
if you go to:
http://www.gulli.com/tools/anoncheck.html
you get an alert:
"c is not a registered protocol"

20021210 on WinXP
(Reporter)

Comment 1

16 years ago
it's the:
<iframe src="c:\"></iframe>
that produces the alert
Summary: URL produces "c is not a registered protocol" → iframe src="c:\" produces "c is not a registered protocol"
(Reporter)

Comment 2

16 years ago
Created attachment 109016 [details]
test case

Comment 3

16 years ago
We corrected the handling of relative URLs, c: is recognized as a protocol handler.

You need to correctly escape the ":", or you might find that "c|" works.
(Assignee)

Comment 4

16 years ago
src="c:\" is not a valid URL.  If they wanted to load the contents of the c:\
 directory, they should try "file://c:" or something (ignoring the fact that
this is also invalid when loaded from a remote site).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
for normal users producing an alert saying "c is not a registered protocol" is
really really weird. The error says nothing about what's going on and where and
how to correct this.

I suggest we remove such a alert and perhaps move it to the javascript console
as an error or something.

At least only show this error if you're running a debug build.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 6

16 years ago
sure, we can do that.  get someone from the front end to agree how unrecognized
protocols should be handled from iframes vs. the url bar.  
We _have_ to show this error if the user clicks on <a href="c:\">.  Simply doing
nothing is not acceptable there.

This is simply a duplicate of the bug on using error pages instead of alerts --
if we showed a nice error page in the iframe it would all be fine.

*** This bug has been marked as a duplicate of 28586 ***

*** This bug has been marked as a duplicate of 28586 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
I think the current error message is correct and should be left as it is. It
exactly says what is going on. c is interpreted as protocol, this might give a
hint to the user/designer that he/she missed the file:/// prefix. After fixing
this he/she will of course get a 404 because of the usage of \ instead of /. 

Using an error page instead of the alert may be acceptable as long as the
message stays the way it is.
Of course.  The error page will likely say something like:

'Unable to load "c:\" because "c" is an unknown protocol'....

Comment 10

16 years ago
REOPEN: duped to wrong bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 11

16 years ago
iframes will not error anymore.

*** This bug has been marked as a duplicate of 196120 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Component: Networking → Embedding: Docshell
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.