HTMLRowElement::deleteCell hides the last cell of a row

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Laurent Pinchart, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

When calling deleteCell on an HTMLRowElement which contains two cells, one of
the cells is deleted and the remaining cell in the row disappears. This only
happens if the table has the "border-collapse: collapse" style. Modifying the
style of the table using the DOM inspector makes the cell reappear.

Reproducible: Always

Steps to Reproduce:
1. Load the attached test case.
2. Click on the "Remove cell" button to remove all the cells one by one.



Expected Results:  
The last cell should not disappear.
(Reporter)

Comment 1

15 years ago
Created attachment 109018 [details]
Test case

Test case
This is a tables reflow bug....
Assignee: jst → table
Status: UNCONFIRMED → NEW
Component: DOM HTML → Layout: Tables
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: stummala → amar
Hardware: PC → All

Comment 3

15 years ago
table reflow?? It asserts like hell in in bc code because there is no col frame
attached to the table.
Keywords: testcase

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future
This worksforme in a current build.  Bernd, I assume your colframe changes fixed
this?

Comment 5

14 years ago
wfm indeed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.