Closed Bug 184889 Opened 19 years ago Closed 18 years ago

fails to try IPv4 address(es) when IPv6 connection fails

Categories

(Core :: Networking, defect)

1.0 Branch
defect
Not set
major

Tracking

()

VERIFIED WONTFIX

People

(Reporter: jgoldsch, Assigned: darin.moz)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/4.72 [en] (X11; I; Linux 2.2.14 i586)
Build Identifier: 

If a site has both IPv4 and IPv6 addresses in DNS, mozilla fails to try the IPv4
addresses after the first IPv6 address fails.

This is a very common occurance if a machines IPv6 address has been put into
DNS, but an IPv6 enabled webserver is not running on this host, only an IPv4
enabled webserver.  Mozilla will attempt to connect the IPv6 address, fail
(because no server was present) and not attempt to try the IPv4 address(es) of
the same server.  This is a serious issue and will certainly stop IPv6 migration
and transition for many sites.

Reproducible: Always

Steps to Reproduce:
1.  add IPv4 and IPv6 address for server into DNS
2.  load an IPv4-only webserver on said server
3.  browse the hostname of server

Actual Results:  
Unable to connect to server

Expected Results:  
Try the IPv6 address and upon failure try the IPv4 addresses
Darin, I believe this is a duplicate of a known bug.
Assignee: wtc → dougt
Status: UNCONFIRMED → NEW
Component: NSPR → Networking
Ever confirmed: true
Product: NSPR → Browser
QA Contact: wtc → benc
Version: other → 1.0 Branch
Summary: nspr fails to try IPv4 address(es) when IPv6 connection fails → Mozilla fails to try IPv4 address(es) when IPv6 connection fails
Reporter:
Which build Do you use ?
(could be a dupe of bug 161228)
reporter:

what version of mozilla are you testing?  i believe bug 161228 (which this
appears to be a duplicate of) was only fixed on the mozilla trunk after we
branched for 1.0.  if Sun needs this bug to be fixed on the 1.0 branch then
you'll have to get in touch with drivers@mozilla.org to discuss getting approval
to land the patch for bug 161228 on the 1.0 branch.

reassign to me.
Assignee: dougt → darin
qa -> ipv6 placeholder.

Jason: we are also going to need a detailed test case, prefernably describing a
public DNS entry so we can look at the config as well.
QA Contact: benc → ipv6
see also bug 163157
Blocks: IPv6
Summary: Mozilla fails to try IPv4 address(es) when IPv6 connection fails → fails to try IPv4 address(es) when IPv6 connection fails
just to add my 0.02$ - the problem also raises if one has loaded ipv6.o but does
not have a working ipv6 setup

So I always fail to load daily.sdinet.de (for expample) if not using a proxy
(yes, incorrect ipv6 setup - my tunnel seems to not work faithfully)
In bug 163157 it refers specifically to connection refused.  In the case of ipv6
support loaded, but no route to the host, this connection fails with no route to
host and no error message is generated (1.3.1).  There is no route to the host
even though there is ipv6 support and a v6 host entry in DNS.  Even though there
is a valid IPv4 host and route, it is not tried.
please see bug 199173... this may just be a duplicate.  the problem might be
fixed now.  unfortunately, i don't have an IPv6 setup to test against. 
Depends on: 199173
bug 199173 doesn't exist anymore in 1.4 but this is 1.0 branch. Is it fixed
there, too?
ah, no.... probably not fixed there.  is that critical to you or your company? 
mozilla.org is not planning anymore 1.0 branch based releases AFAIK.  you may
want to be in touch with drivers@mozilla.org if you have special interest in the
1.0 branch.  otherwise, 1.4 is slated to replace the 1.0 branch.
It's not important for me. I just wanted to clarify that this bug is 1.0 branch.
THX
then i'm going to say WONTFIX here.... we're really really close to shipping 1.4
and as i said it is slated to replace 1.0 as the stable branch.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
V: per module owner.
Status: RESOLVED → VERIFIED
QA Contact: ipv6 → networking
You need to log in before you can comment on or make changes to this bug.