If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unable to login or access FTP sites

RESOLVED DUPLICATE of bug 124561

Status

()

Core
Networking: FTP
RESOLVED DUPLICATE of bug 124561
15 years ago
15 years ago

People

(Reporter: Aaron, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2.1) Gecko/20021130

an alert says - You do not have proper permissino to access this site
It is a site I should have complete access to.

Reproducible: Always

Steps to Reproduce:
1. Go to any FTP site

Actual Results:  
site did not load. alert said not proper permissions

Expected Results:  
loaded site and continued to load a login screen
Do you use a proxy or firewall ?
Can you please give us an example FTP URL ?
OS: other → Windows 98
Summary: unable to login or acces FTP sites. → unable to login or acces FTP sites.

Comment 2

15 years ago
In order to reproduce this bug no proxies or firewalls are required. I tried to
connect via ftp from different workstations (e.g. home, office), but it's all
the same.
A sample FTP URL which does not raise a login prompt but causes "alert 530" is
ftp://www.vegan.com

Comment 3

15 years ago
Somehow I don't think ftp://www.... is a valid anonymous ftp URI. No problem
reaching ftp://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/ in 2003011608
W32 trunk. Maybe you should try a newer build from this location.

Comment 4

15 years ago
Aaron: Does "It is a site I should have complete access to" mean that you have a
username and password?

Type:

ftp://USER@ftp.vegan.com

Mozilla will ask you for a password... see if it works.

Felix: any ftp site can be configured to accept anonymous ftp access, even a
site named "www..."

Comment 5

15 years ago
Ok, it is not a bug, it is just an undocumented feature. Using the scheme above
(ftp://USERNAME@URL) works fine. Thanks for the hint.

Comment 6

15 years ago
FTP's current design is mostly for browsers, and assumes the ftp URLs will work
when accessed directly. There is some discussion about how username errors
should be handled (assuming the error message is parsable).

Please mark this bug VERIFIED/dupe if you believe this bug is the same as the
bug I have duped.

*** This bug has been marked as a duplicate of 124561 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: unable to login or acces FTP sites. → unable to login or access FTP sites
You need to log in before you can comment on or make changes to this bug.