expanding a server's newsgroup list should not force downloading msg counts for all groups

RESOLVED DUPLICATE of bug 34591

Status

MailNews Core
Networking: NNTP
--
enhancement
RESOLVED DUPLICATE of bug 34591
16 years ago
10 years ago

People

(Reporter: John T, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

With many groups subscribed, the downloading of new-msg counts for all groups is
very time-consuming and needlessly slows down activity of other operations when
only one or a few groups are of interest at a particular time. Expanding a
newsgroup list by clicking on a server should only expand the list. Why not
leave the list in an expanded state so individual groups can be selected? After
the list is expanded, another click on the server to download new-msg counts
would be ok, but not before the first click merely expands the list.

Reproducible: Always

Steps to Reproduce:
1. Open mail/news window sidebar
2. click on news server
3. 

Actual Results:  
Mozilla expands the server into the associated list of subscribed groups and
then downloads the numbers of new messages for each group. 

Expected Results:  
Only expand the list on the first click. If the user clicks on the server after
the subscribed list is expanded, then it should download the number of new
messages for each group.

The suggestion in "Expected Results" would save bandwidth and processing time,
as well as giving the user a sense that Mozilla has some fine-grained controls
instead of just course clumsy controls.

This option was available in NS 4.08, along with the Collabra window. NS 4.08
was considerably more suitable for newsgroup access than the current version of
Mozilla. This is a usability issue---trying to encourage Mozilla developers to
get back to the usability of NS 4.x in newsgroup access.
Related to, but not a duplicate of bug 72318.  Confirming, but setting to
enhancement, as this is currently to-spec.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
Set news.update_unread_on_expand to false.
No longer blocks: 71728
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 34591
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.