Closed Bug 184928 Opened 17 years ago Closed 17 years ago

DIV using absolute position causes under- or overlying clickable region to become inert.

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 102695

People

(Reporter: rrkramer, Assigned: jst)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

The example has two buttons, one of which is partially "inside" a DIV, the other
wholely. The DIV is positioned via position: absolute. The portions of the
buttons inside the DIV are not clickable. Futzing with z-index seems to have no
effect.

Reproducible: Always

Steps to Reproduce:
1.Try to click the right hand "ClickMe" button.
2. Click the left side of the left button.

Actual Results:  
1. Zilch
2. An alert dialog appeared, announcing that "It worded."

Expected Results:  
In both cases, I expected to see the alert dialog.

This looks similar to bug#35440.
Is this a dupe of bug 178569?
I see the behavior described in today's Linux, OS/2 & W32 trunks. Would mark new
except that I have no idea that this isn't WAD.
The div is above the buttons, so it catches the mouse events.  

z-index only applies to positioned elements, so setting it on the button in 
that testcase does absolutely nothing.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.