barcelo.com - central page does not load in frameset

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: amutch, Assigned: tristan)

Tracking

Details

(Whiteboard: [havecontact][XBROWSER-JS], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

The central page in this frameset loads in IE 6 but doesn't load in Mozilla 1.2.1.

Reproducible: Always

Steps to Reproduce:
1. Load page: http://www.barcelo.com/hotels/seleho_i.htm
2. No page appears in the center of the frameset
3.

Actual Results:  
No page appears in the center of the frameset

Expected Results:  
Page should appear showing content of center page in frameset. 

I'm guessing that this is an evangelism issue. It's possible it's a problem with
Mozilla but I doubt it.
bas JS sniffing :
// ************************************************************
// Inicializaciones para discernir entre Netscape4 y Explorer4
// ************************************************************

var ns4 = (document.layers)?true:false;
var ie4 = (document.all)?true:false;

if (ns4) {
  doc = "document";
  sty = "";
} else {
  doc = "document.all";
  sty = ".style";
}

Their booking site (barcelo-viajes.es) is unusable with Mozilla too.

Contacts :
jmesquida@barcelo-viajes.es
clientes@barcelo.com <clientes@barcelo.com>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [havecontact]

Updated

16 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: Central page doesn't load in frameset → barcelo.com - central page does not load in frameset
Whiteboard: [havecontact] → [havecontact][XBROWSER-JS]

Comment 2

16 years ago
As near as I can tell, this is *not* a bug in Mozilla. The central page at that
site is coded as follows:

var ns4 = (document.layers)?true:false;
var ie4 = (document.all)?true:false;

if (ns4) {
  doc = "document";
  sty = "";
} else {
  doc = "document.all";
  sty = ".style";
}

then uses eval(doc + "whatever" + sty);

So the page is poorly written and assumes that if it isn't Netscape 4
(document.layers), then it's IE (document.all). Obviously since Netscape
7/Mozilla supports neither document.layers, nor document.all, this page is not
going to work in Netscape 7/Mozilla. It even generates these two client-side
JavaScript errors as a result of this sloppy client-side coding:

Error: esqObj has no properties
Source File: http://www.barcelo.com/barrainf/binf_h_i.htm
Line: 49

Error: document.all has no properties
Source File: http://www.barcelo.com/hotels/selec_i.htm
Line: 30

The site's author should probably consult <url:
http://www.mozilla.org/docs/web-developer/upgrade_2.html /> for tips on
re-writing his page to properly support Netscape 7/Mozilla.
Grant, we know that this is not a bug in Mozilla, that's why it is filed as Tech
Evangelism
another who has learned
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
move tristan's resolved euro west bugs to other
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.