After printing page 1-#x when a doc is 1-more than #x , print preview is only showing x# of pages

RESOLVED DUPLICATE of bug 186394

Status

()

Core
Print Preview
--
major
RESOLVED DUPLICATE of bug 186394
16 years ago
15 years ago

People

(Reporter: Gordini, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Summary :After printing page 1-#x when a doc is 1-more than #x , print preview
is only showing x# of pages .. restart mozilla only solution



Reproducible: Always

Steps to Reproduce:
If i paste a url www.xyz.com/abc.html into mozilla and does Print Preview
it shows 10pages

I choose to print pages 1-4

all well so far

But when i paste in a new url .. same browser www.xyz.com/def.html

and does Print Preview it only shows "visual" pages 1-4.


Expected Results:  
it should have "visualy" showed me all pages

Comment 1

16 years ago
Can confirm this for 1.2.1 / w2k and
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210
and arbitrarily choosen pages.

Happens not only on selecting a subset of pages but also with choosing landscape
format. Seems like, Mozilla takes the last values from the printer drivers
properties, even though the printer driver resets them.

Have also tried this with different printer driver (some hp ps/pcl, adobe
acrobat pdfwriter).

Comment 2

15 years ago
CONFIRMING.

I have encountered this phenomenon on 2 different computers, with every version
of App Suite, Phoenix, and Firebird I have ever used.

Recent examples of releases exhibiting this behavior include:

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4b) Gecko/20030519 Mozilla
Firebird/0.6

Mozilla 1.3.1
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3.1) Gecko/20030425

And it is not only "1-#x".  It applies to any number of selected pages other
than All pages.  If I print only pages 2 and 3, then that's all I will see on
the next preview.  If I print only page 2, ditto.  If the next web page I
preview would print to only one paper page, then preview shows nothing.

Dupping to bug that's already "new"

*** This bug has been marked as a duplicate of 186394 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.