Can't drag-select in text widget unless focussed first

VERIFIED FIXED in M13

Status

()

P2
major
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: sfraser_bugs, Assigned: buster)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When I open a new browser window, the first thing I want to do is select the text
in the URL bar to replace it. I do this by clicking after the text, and dragging
leftwards.

The problem is that this first click-drag does nothing, presumably because it
takes one click to focus the text field. We need to set focus on the first mouse
down, so that this first click-drag both sets focus, and selects.
(Assignee)

Updated

19 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M13
(Assignee)

Comment 1

19 years ago
yeah, I know about this one.  thanks for the bug.  I don't think this is
dogfood, but it is pre-beta.  Setting to M13.  It's about 1 day of work.

Comment 2

19 years ago
I see this problem on windows too. That's the first thing I do when I fire it up
too :).
(Assignee)

Updated

19 years ago
Depends on: 21612
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
fixed.  not part of M12 unless they do a respin.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
verified in 12/17 build.
You need to log in before you can comment on or make changes to this bug.