profiles.emailflags initialised with NULL but default in userprefs.cgi is every thing checked

RESOLVED DUPLICATE of bug 108870

Status

()

Bugzilla
Email Notifications
--
minor
RESOLVED DUPLICATE of bug 108870
16 years ago
6 years ago

People

(Reporter: okoltermann, Assigned: preed)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)
Build Identifier: Bugzilla 2.16.1

If a new user signs up the database initializes the mentioned field with a NULL 
value. As a result the "ExcludeSelf" flag is not set. So the user gets mail 
notification about his own actions. When visiting userprefs.cgi, the 
corresponding checkbox defaults to checked and the database is updated. So the 
behavior changes if the user first visits the settings.
Maybe depending on bug 128422.

Reproducible: Always

Steps to Reproduce:
1. Create new user account
2. Look at database: profiles.emailflags = NULL
3. If possible: Change a bug which is assigned to the new user under the new 
user
4. User gets notification
5. Look at prefs/email: Only email me reports of changes made by other people 
is CHECKED. Don't submit the page!
6. Look again at database: profiles.emailflags = 
ExcludeSelf~on~emailOwnerRemoveme...
Actual Results:  
After first time viewing the userprefs.cgi everything is normal.

Expected Results:  
New user profile should match default userprefs.cgi or mailer should assume 
same default on "NULL" as userprefs.
(Reporter)

Comment 1

16 years ago
The same problem exists on this installation of Bugzilla (2.17.1). I got the 
notification mailing after submitting the bug report. Now I visited the email 
preferences and hope that no notification arrives after submitting this 
comment...
(Reporter)

Comment 2

16 years ago
OK, no notification for last entry.

Added dependencies to bugs mentioning similar behavior but closed because of 
reproducibility. Again: Problem clears itself after first visiting the 
userprefs.cgi.
Severity: normal → minor
Depends on: 124916, 128422
the email guys deal with this...
Assignee: myk → preed
Component: User Accounts → Email Notifications
No longer depends on: 124916, 128422
but it's a dupe.

*** This bug has been marked as a duplicate of 108870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.