Mozilla takes huge amounts of memory on startup

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Ren Hoek, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021209
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021209

I got a PC here at work running WinXP with only 128MB of memory. Sometimes when
starting the Mozilla browser (No quicklaunch active) the system will start
swapping like crazy. It can take several minutes for Mozilla to start up.
Usually I just end up killing the process and restarting it.

I looked at it with the task manager. In one instance Mozilla eats up memory
until it reaches 75MB, falls all the way back to a few hundred kilobytes, grows
to 12,5MB and then presents me with a browser window.

This behaviour has been consistant over the last few official release builds.
Weird thing is, that if I kill Mozilla with the task manager and restart it, it
will come up normally within a few seconds. I'm keeping in mind that part of the
memory will already be swapped out, however there is not that much free memory
so that I wouldn't notice this problem happening again.

Only reason I can think of is that if Mozilla reads all my mailboxes to memory
verbatim (2x 44MB) but the behaviours is not consistant, and I'm launching the
browser not the mail client. Most of the time launching Mozilla goes just fine
even when I'm running a lot of other applications. It's weird..

Reproducible: Sometimes

Steps to Reproduce:
1. Get a computer running WinXP with not too much memory onboard
2. Start Mozilla
3.



Expected Results:  
Mozilla should open the browser without allocating HUGE chunks of memory when
starting.

I presume this behaviour might be related to the plugins that are loaded with
Mozilla (unsure if this is load-on-demand, or run-at-launch) so I'm including my
plug-in info page as an attachment
(Reporter)

Comment 1

16 years ago
Created attachment 109122 [details]
List of plugins installed
(Reporter)

Comment 2

16 years ago
Created attachment 112505 [details]
Memory usage graph

Included part of a screenshot of the WinXP Taskmanager's memory usage graph. A
description of the events:

Start: Pushed button on quicklaunch bar: "C:\Program Files\Mozilla\mozilla.exe"
-nosplash -mail

Terminated: I noticed it went wrong again so I terminated mozilla.exe in the
task manager's process list

Start 2: Clicked the same button again, as you can see it hardly asks for any
memory, and boots up quickly. The little spike in the second run is when it is
getting the mail but remains stable after that.

Taskmanager's update speed was set to normal. No programs were used, started or
terminated in the meantime. Memory usage after 'start 2' was stable at 268 MB
for the entire system.

Comment 3

16 years ago
This happens to me too. I use Linux version. On about 20% of the Mozilla
startups, all my memory and swap are taken, sometimes making my entire system to
hang. I workarounded this by putting an "ulimit -v 65536" on my mozilla script
(unfortunatelly, there is no way on doing the same thing in windows).

Comment 4

16 years ago
I had the almost the same problem, but Mozilla 1.2.1 went into an endless loop
(I think) and taking up to 300Mb of virtual memory (until I killed it).

I tried to find the error deleting selectively the files on "\Document and
Settings\<user>\Program Data\Mozilla\..." and I found that erasing registry.dat
the problem was solved, but preferences web out.

Another thing that I tried (after restoring the original and wrong registry.dat)
was to install Mozilla 1.3b on another directory, but taking the original
profiles. When it was installed both browsers worked fine and the problem
disapeared even when I desinstalled the 1.3b version and restored the
registry.dat file.

Comment 5

15 years ago
Reporter, do you still see this problem with the latest nightly (or even 1.5)?
If not, this bug can be closed, since a lot of memory usage fixes have been
added over time. Thanks.

Comment 6

15 years ago
I'm going to go ahead and resolve this worksforme, the latest version of Mozilla
mentioned in the bug is 1.3b which is nearly a year old. If someone is able to
reproduce this in a recent build, please feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.