Message handling performance tremendously down in 1.2.1

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Volker Widlok, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

"Mark as read" is very slow. Copying, moving and deleting messages causes havy
I/O (Harddisk works very noisy, over all system performance is down). E.g.
moving 1000 Messages from one folder to another takes about 30mins (in 1.1 5
secs). Receiving messages performance is very low too. It grabs 1-3 Messages at
a time and freezes for about 3-10 secs before receiving the next. I installed
1.2.1 several times on W2K and XP. Always the same behaviour. Had to migrate
back to 1.1. It's a show stopper for me.

Reproducible: Always

Steps to Reproduce:
1. move/copy messages (at least about 10-15) between folders
2. delete messages from folders, empty trash folder
3. send yourself at least 20 messages and watch the "# of # messages" counter in
the status bar

Actual Results:  
see Details

Expected Results:  
working as fast as in version 1.1. In this condition the messenger is useless.

Comment 1

15 years ago
dup of bug 182263?

Updated

15 years ago
QA Contact: olgam → laurel
(Reporter)

Comment 2

15 years ago
i wouldn't consider this as a dup of 182263. perhaps an extention. this tickets
just describes the compact-folder funktion and has SEV normal. But that doesn't
describe the whole problem. As a matter of fact, the whole I/O handling in 1.2.1
is screwed up and this makes it unusable for me and i guess for many others too.
At least for those the SEV is "blocker" but it's definitely higher than normal.

Comment 3

15 years ago
there's also related bug 180516
Reporter, both the related bug appears fixed, could you please retest with a
newer version og mozilla, either the latest (stable) milestone or a recent nightly.

Comment 5

14 years ago
Please reopen if you can still reproduce with 1.7alpha or newer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.