Drag & Drop of attachment from received message to desktop creates shortcut instead of saving attachment

RESOLVED DUPLICATE of bug 83803

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 83803
15 years ago
13 years ago

People

(Reporter: Mike Fedyk, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: edt_x3)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

Drag & Drop from received message to desktop creates shortcut instead of saving
attachment

Reproducible: Always

Steps to Reproduce:
1. Receive a message with an attachemtn
2. Resize mozilla 3-pane, or double click on the message so you can see the
desktop or an explorer window at the same time as the message attachment listing.
3. Drag & drop from message to explorer/desktop

Actual Results:  
A shortcut is created instead of a file with the contents of the attachment. 
And if you click open the shortcut you get two error messages:

Unable to open this internet shortcut. The protocol "mailbox" does not have a
registered program.

<press ok>

Unable to open Internet Shortcut "<path>file.pdf.url".

Expected Results:  
Save contents of attachment instead of creating a shortcut.

Updated

15 years ago
QA Contact: olgam → gchan

Comment 1

15 years ago
20030225 Builds - Win2k - confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: edt_x3

Comment 2

15 years ago
It's possible now to hook up stuff in a drag to allow for file saving (see bug
193053). Whehter we need to wrap this in another layout, to make it easier for
apps like mail to save attachments, is an open question.
Depends on: 193053
OS: Windows NT → All
Hardware: PC → All

Comment 3

15 years ago
er, s/layout/layer
(Reporter)

Comment 4

15 years ago
Any plans for this bug now that that the DnD merge has landed?

Updated

15 years ago
Summary: Drag & Drop from received message to desktop creates shortcut instead of saving attachment → Drag & Drop of attachment from received message to desktop creates shortcut instead of saving attachment
2003060208 build - Win2k - confirmed.

Comment 6

15 years ago
*** Bug 198164 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 212401 has been marked as a duplicate of this bug. ***
confirmed win2k 1.5rc1
dependency is cleared ?

Comment 10

14 years ago
Isn't this basically bug 83803?  (See particularly bug 83803 comment 12 which 
mentions the creates-a-link-instead issue, and also gives a hint on why this 
isn't in place yet.)

Comment 11

14 years ago
*** Bug 226312 has been marked as a duplicate of this bug. ***
works for me on winxp 1.7b build 2004031508

great news !!

Comment 13

14 years ago
Yep; the duplicate has been fixed.

*** This bug has been marked as a duplicate of 83803 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.