Crash visiting listbox.xml XBL file in chrome

RESOLVED WORKSFORME

Status

()

Core
XUL
P5
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: WeirdAl, Assigned: janv)

Tracking

({crash, testcase})

Trunk
Future
x86
All
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Mozilla 1.2.1 build, Win98SE.  Visiting URL given in this bug results in a
crash.  No idea why...

Talkback ID TB15025793Z (stackwanted keyword)

Comment 1

15 years ago
Created attachment 109174 [details]
Talkback Report

nsGrid::GetScrollBox
[c:/builds/seamonkey/mozilla/layout/xul/base/src/grid/nsGrid.cpp, line 1492]
nsGridRowLeafLayout::ComputeChildSizes
[c:/builds/seamonkey/mozilla/layout/xul/base/src/grid/nsGridRowLeafLayout.cpp,
line 323]
nsSprocketLayout::Layout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsSprocketLayout.cpp, line
264]
nsContainerBox::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 609]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line
1066]
nsBoxFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 900]
nsLineLayout::ReflowFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineLayout.cpp, line 1048]
(Reporter)

Comment 2

15 years ago
Thanks jkeiser.
Keywords: stackwanted

Comment 3

15 years ago
Hmm, but that file gets loaded as text/xml, not as XUL, so what the heck
is it doing in nsGrid.cpp? And when I set a breakpoint where the stack says
it crashes, and load chrome://.../listbox.xml in the browser, I never hit
that code. And I definitely don't crash with today's trunk build on win2k.
Assignee: hyatt → varga
Component: XBL → XP Toolkit/Widgets: Trees
QA Contact: ian → shrir
(Reporter)

Comment 4

15 years ago
I would venture it's probably involving an XUL namespace in the XBL file.
(Assignee)

Comment 5

15 years ago
I tried with mozilla 1.0.1 and it crashes.
I tried with mozilla 1.2.1 and it doesn't crash, probably because the file is
"pretty-printed"
OS: Windows 98 → All
Priority: -- → P5
Target Milestone: --- → Future

Comment 6

15 years ago
Crashed on me, WinXP SP1 trunk build 2002121308

Talkback ID TB15072784E
TB15072784E is the same stack as in comment 2

Product ID  MozillaTrunk    
Build ID  2002121308

Comment 8

15 years ago
I got one crash in five tries on winMe with mozilla 1.2.1 and had this stack.

    nsListBoxBodyFrame::ComputeTotalRowCount   
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 
829]
     nsListBoxBodyFrame::GetRowCount 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 
667]
     nsListBoxLayout::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsListBoxLayout.cpp, line 68]
     nsContainerBox::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 502]
     nsBoxFrame::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 983]
     nsListboxScrollPortFrame::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 
1581]
     nsGfxScrollFrame::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 
743]
     nsSprocketLayout::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsSprocketLayout.cpp, line 
1306]
     nsGridRowGroupLayout::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/grid/nsGridRowGroupLayout.cpp, 
line 114]
     nsContainerBox::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 502]
     nsBoxFrame::GetPrefSize 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 983]
     nsBoxFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 860]
     nsLineLayout::ReflowFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineLayout.cpp, line 1048]
     nsBlockFrame::ReflowInlineFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3902]
     nsBlockFrame::DoReflowInlineFrames 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3730]
     nsBlockFrame::DoReflowInlineFramesAuto 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3634]
     nsBlockFrame::ReflowInlineFrames 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3579]
     nsBlockFrame::ReflowLine 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2653]
     nsBlockFrame::ReflowDirtyLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2297]
     nsBlockFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
     nsBlockReflowContext::ReflowBlock 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, 
line 537]
     nsBlockFrame::ReflowBlockFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3337]
     nsBlockFrame::ReflowLine 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2519]
     nsBlockFrame::ReflowDirtyLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2297]
     nsBlockFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
     nsBlockReflowContext::ReflowBlock 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, 
line 537]
     nsBlockFrame::ReflowBlockFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3337]
     nsBlockFrame::ReflowLine 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2519]
     nsBlockFrame::ReflowDirtyLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2297]
     nsBlockFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
     nsContainerFrame::ReflowChild 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 
949]
     CanvasFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsHTMLFrame.cpp, line 570]
     nsBoxToBlockAdaptor::Reflow 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 
929]
     nsBoxToBlockAdaptor::DoLayout 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 
670]
     nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, 
line 1066]
     nsScrollBoxFrame::DoLayout 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsScrollBoxFrame.cpp, line 
361]
     nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, 
line 1066]
     nsContainerBox::LayoutChildAt 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 651]
     nsGfxScrollFrameInner::LayoutBox 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 
1164]
     nsGfxScrollFrameInner::Layout 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 
1323]
     nsGfxScrollFrame::DoLayout 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 
1172]
     nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, 
line 1066]
     nsBoxFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 900]
     nsGfxScrollFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 
850]
     nsContainerFrame::ReflowChild 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 
949]
     ViewportFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsViewportFrame.cpp, line 
579]
     PresShell::InitialReflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 2841]
     nsXMLContentSink::StartLayout 
[c:/builds/seamonkey/mozilla/content/xml/document/src/nsXMLContentSink.cpp, 
line 1299]
     nsXMLContentSink::DidBuildModel 
[c:/builds/seamonkey/mozilla/content/xml/document/src/nsXMLContentSink.cpp, 
line 430]
     nsExpatDriver::DidBuildModel 
[c:/builds/seamonkey/mozilla/htmlparser/src/nsExpatDriver.cpp, line 973]
     nsParser::DidBuildModel 
[c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp, line 1265]
     nsParser::ResumeParse 
[c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp, line 1811]
     nsParser::OnStopRequest 
[c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp, line 2440]
     nsDocumentOpenInfo::OnStopRequest 
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 257]
     nsJARChannel::OnStopRequest 
[c:/builds/seamonkey/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp, line 
609]
     nsOnStopRequestEvent::HandleEvent 
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 
213]
     PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 
645]
     PL_ProcessPendingEvents 
[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 578]
     nsEventQueueImpl::ProcessPendingEvents 
[c:/builds/seamonkey/mozilla/xpcom/threads/nsEventQueue.cpp, line 392]
     0x26eb86b1 


But this is reasonably set as a P5/Future because loading chrome:// urls into 
the browser is not supported. Don't do that :-)

If anyone can demonstrate that "XML pretty printing" doesn't work over http,
then that would be a bug.
(Reporter)

Comment 9

15 years ago
jrgm: On a Mozilla 1.2b build on a laptop also running Win98SE, loading the 
file via the file:// protocol (after unzipping it from the toolkit.jar file 
in /bin/chrome), I got the same crash as viewing it via chrome:// protocol.

Ironically, on the same 1.2.1 build I crashed yesterday on, I cannot reproduce 
the crash, and I don't know why.

Comment 10

14 years ago
No crash with Moz 1.7 Beta: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040316

I get this message at the top: "This XML file does not appear to have any style
information associated with it. The document tree is shown below."

Comment 11

14 years ago
Closing this bug as WORKSFORME. No crash with either the chrome:// or the
file:// protocols, and the builds used to report this bug are over a year old. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 12

14 years ago
Adding CC (meant to do this before, already hit commit when I remembered)

Sorry for spam.

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.