If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Quicksearch bookmarks should prompt a dialog input box when clicked on

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
15 years ago
5 years ago

People

(Reporter: blitzreiter, Unassigned)

Tracking

unspecified
Future
x86
All
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix?, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Using the builtin dictionary bookmark in the menu opens webster but the content
is broken.

"Get the Top 10 Most Popular Sites for "�REQUEST_URI=/cgi-bin/dictionary?va=�s"
For More Information on "�REQUEST_URI=/cgi-bin/dictionary?va=�s" go to
Britannica.com
Find Photos, Magazines and Newspaper Articles about
"�REQUEST_URI=/cgi-bin/dictionary?va=�s" at eLibrary. Free registration required."

note that I didn't specify anything to search for.

Reproducible: Always

Steps to Reproduce:
1.use link above
2.Or use menu - quick searches - dictionary
3.

Actual Results:  
As stated above the site looks broken

Expected Results:  
perhaps give different parameters or check whether there is blank input submitted.

Comment 1

15 years ago
This is a quicksearch item, not a normal bookmark.
It's not made to be clicked, but to be used in the URIbar.
Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
What??? It is in the "bookmark" menu. A user does not chck waht it is intended
to be. Anyway it is broken and has to be fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

15 years ago
blitzreiter, as Sébastien explained, this bookmark is not a regular one. It is
used in conjunction with a user input in the url bar.
Though, I agree that the current behaviour is flawed. When such a bookmark is
clicked on, a dialog should popup to get this input.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

15 years ago
I am sorry, it happens in my Phoenix 0.5. version I downloaded. So does quick
search not belong to the Phoenix distribution?

Since it is in the bookmark menu.
Since it is accesible as a bookmark
Since no user cares about what a option is intended to be for
Since there is a problem that can easiely be reproduced with my unaltered
Phoenix 0.5 (bookmarks - quick searches - dictionary quicksearch) 

To my mind quick search shall be totally removed from this bookmark menu and be
attached to the input button selector (like dmoz.org). Another option was to
open webster with no input when input was blank like an ordinary bookmark.
In this case
http://www.webster.com/home.htm
would be the correct URL.

Comment 5

15 years ago
Setting OS to All and updating summary, since this is about quicksearch
bookmarks in general.
OS: Windows 98 → All
Summary: Dictionary bookmark → Quicksearch bookmarks should prompt a dialog input box when clicked on
(Reporter)

Comment 6

15 years ago
It could also be a good idea to talk to Webster to fix this problem on their site. 
That may be easier if they avoided the error message on their site by detecting
a  blank input. 
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 8

14 years ago
The solution to this would be to check if there is a %s in the link when loading
the bookmark and if there is, then pop up a dialog box to get the input. Ideally
typing a keyword without the term would pop up the same dialog. 

Example

The bookmark entry is as follows:

Bookmark Name: Google Quicksearch
Bookmark Keyword: google
Bookmark Description: Perform a search on Google
Bookmark Location: http://www.google.com/search?&q=%s

If the user were to click on the bookmark or type 'google<enter>' in the
location bar, the following dialog would pop up:

+--------------------------------------------------------+
| Perform a search on Google:                            |
|    |_______________________________________ [Search]   |
|                                                        |
| Note: You can simply type 'google <term>' in the       |
|       location bar to perform this search.             |
+--------------------------------------------------------+

Note that the introductory text is the Bookmark Description, if one isn't
present, the bookmark name should be used. Also the keyword in the note text is
filled in automagically.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 10

9 years ago
This would be great for making quick searches more public, plus the add of the search in the awesomebar made some time ago.
Flags: blocking-firefox3.1?
Definitely not blocking, too late for features so not setting wanted.
Flags: blocking-firefox3.1? → blocking-firefox3.1-

Updated

9 years ago
Assignee: p_ch → nobody
Severity: normal → enhancement
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
Target Milestone: --- → Future

Updated

9 years ago
Whiteboard: wontfix?

Updated

9 years ago
Duplicate of this bug: 253457
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
We no longer have default quicksearch bookmarks, and don't plan to expand their use much.
Status: NEW → RESOLVED
Last Resolved: 15 years ago5 years ago
Resolution: --- → INVALID
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.