Crash in imagelib - nsImageBoxFrame::OnStopDecode

VERIFIED DUPLICATE of bug 184916

Status

()

--
critical
VERIFIED DUPLICATE of bug 184916
16 years ago
4 months ago

People

(Reporter: tever, Assigned: jdunn)

Tracking

({crash, platform-parity})

Trunk
x86
Windows NT
crash, platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Overview Description:  Internal page crashes browser.

Steps to Reproduce:
1.) go to site

Actual Results:  client crashes

Build Date & Platform Bug Found:  Win NT4 2002121108

Additional Builds and Platforms Tested On:  works on mac osX

Additional Information:  stack trace

MSVCRT.dll + 0xd008 (0x7800d008)
MSVCRT.dll + 0xc730 (0x7800c730)
MSVCRT.dll + 0x12d7 (0x780012d7)
nsImageBoxFrame::OnStopDecode
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsImageBoxFrame.cpp, line 803]
nsImageListener::FrameChanged
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsImageFrame.cpp, line 2431]
imgRequestProxy::OnStopDecode
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 359]
imgRequest::OnStopDecode
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 528]
nsICODecoder::Close
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/bmp/nsICODecoder.cpp, line
156]
imgRequest::OnStopRequest
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 673]
ProxyListener::OnStopRequest
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgLoader.cpp, line 871]
nsStreamListenerTee::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsStreamListenerTee.cpp, line 66]
nsHttpChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 3020]
xpcom.dll + 0x4d2dc (0x61dfd2dc)
(Reporter)

Updated

16 years ago
Keywords: crash
(Reporter)

Updated

16 years ago
Keywords: pp
(Assignee)

Comment 1

16 years ago
I believe this to be a dup of bug 184916
which Christian Biesinger just checked a fix in for.

However, I can't reproduce this on win2k, so I
can't verify that the fix works.  tever can you
check if tomorrow's (12/14) builds clean this up?  THANKS

In the mean time I will try to reproduce on Linux
(Assignee)

Comment 2

16 years ago
re-assigning
Assignee: pavlov → jdunn
(Reporter)

Comment 3

16 years ago
ok, this works now.  Tested the later 12/13 builds which apparently have the
patch from 184916.   WinNT4, linux rh6, mac osX all working.



*** This bug has been marked as a duplicate of 184916 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED

Updated

4 months ago
Product: Core → Core Graveyard

Updated

4 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.