crashes when pointed at url

VERIFIED DUPLICATE of bug 184916

Status

()

Core
Networking: HTTP
--
critical
VERIFIED DUPLICATE of bug 184916
16 years ago
14 years ago

People

(Reporter: Max Waterman, Assigned: Darin Fisher)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212

Yesterday(11DEC2002)'s build worked fine, but todays crashes reliably and only
(for the sites I visit) when pointed at the above URL.

Happens 100% on Mac OS X, but only sometimes on IRIX.

Reproducible: Always

Steps to Reproduce:
1.visit http://www.dpreview.com/
2.
3.

Actual Results:  
browser crashes

Expected Results:  
no crash
Please always attach a OS X crash log if possible.

(see the workound in comment#1 in that bug)

*** This bug has been marked as a duplicate of 184916 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Please don't post the stack directly in the bug, use "create new attachment".

Can you please disable the web-site icons (edit\prefern..\appareance\[] Show Web
Site Icons and try again ?
Please reopen if you still crash.

(Reporter)

Comment 3

16 years ago
> Please don't post the stack directly in the bug, use "create new attachment".

That only allows you to attach whole files, not parts of them. I would have had
to create a new file just to do that, and that isn't worth my time.

Please implement a facility to allow attachments of pasted text.

>
> Can you please disable the web-site icons (edit\prefern..\appareance\[] Show Web
> Site Icons and try again ?

Yes. I don't get a crash when I disable that option.

> Please reopen if you still crash.

OK, I won't reopen then, and will assume this is covered by some other bug.

Thanks.

Max.
stack trace for this crash as pasted in bug 184916:
------- Additional Comment #18 From Max Waterman  2002-12-12 17:37 -------

Info as requested - ref: http://www.dpreview.com/ crashes

**********

Date/Time:  2002-12-12 17:30:53 -0800
OS Version: 10.2.2 (Build 6F21)
Host:       blighty-1.csd.sgi.com

Command:    Mozilla
PID:        1176

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xd3445888

Thread 0 Crashed:
 #0   0x0022de30 in Block_link
 #1   0x0022e628 in deallocate_from_var_pools
 #2   0x0022ec68 in _pool_free
 #3   0x0022ef50 in free
 #4   0x001e16a0 in PR_Free
 #5   0x002853b4 in nsVoidArray::SizeTo(int)
 #6   0x00286578 in nsAutoVoidArray::SizeTo(int)
 #7   0x00286510 in nsAutoVoidArray::Clear(void)
 #8   0x021b3ccc in nsHttpHeaderArray::Clear(void)
 #9   0x021b7b50 in nsHttpResponseHead::Reset(void)
 #10  0x02197f9c in 0x2197f9c
 #11  0x021a0a64 in nsHttpChannel::Release(void)
 #12  0x002fa2e4 in nsCOMPtr_base::_dt(void)
 #13  0x021b8b54 in nsHttpTransaction::_dt(void)
 #14  0x021ba5a8 in nsHttpTransaction::DeleteSelfOnConsumerThread(void)
 #15  0x021ba888 in nsHttpTransaction::Release(void)
 #16  0x002fa2e4 in nsCOMPtr_base::_dt(void)
 #17  0x0219452c in nsOnStopRequestEvent::_dt(void)
 #18  0x02193e24 in nsARequestObserverEvent::DestroyPLEvent(PLEvent *)
 #19  0x002d20fc in PL_DestroyEvent
 #20  0x002d2080 in PL_HandleEvent
 #21  0x002d1e9c in PL_ProcessPendingEvents
 #22  0x00279b3c in nsEventQueueImpl::ProcessPendingEvents(void)
 #23  0x0291ce8c in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #24  0x0291cd30 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #25  0x02047b14 in Repeater::DoRepeaters(EventRecord const &)
 #26  0x02933ab8 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #27  0x029337f0 in nsMacMessagePump::DoMessagePump(void)
 #28  0x029330fc in nsAppShell::Run(void)
 #29  0x028f224c in nsAppShellService::Run(void)
 #30  0x001a41b4 in main1(int, char **, nsISupports *)
 #31  0x001a4c0c in main

Thread 1:
 #0   0x9000566c in syscall
 #1   0x90515d9c in BSD_waitevent
 #2   0x9051576c in CarbonSelectThreadFunc
 #3   0x90021268 in _pthread_body

Thread 2:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x9051dda0 in CarbonOperationThreadFunc
 #3   0x90021268 in _pthread_body

Thread 3:
 #0   0x90042ba8 in semaphore_timedwait_signal_trap
 #1   0x9003edd4 in _pthread_cond_wait
 #2   0x90233438 in TSWaitOnSemaphoreCommon
 #3   0x9023c258 in TimerThread
 #4   0x90021268 in _pthread_body

Thread 4:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x9023341c in TSWaitOnSemaphoreCommon
 #3   0x90248aec in AsyncFileThread(void*)
 #4   0x90021268 in _pthread_body

Thread 5:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x901490a8 in __CFRunLoopRun
 #3   0x9018157c in CFRunLoopRunSpecific
 #4   0x901488f8 in CFRunLoopRun
 #5   0x0314f2c8 in -[MyCameraCentral wiringThread:]
 #6   0x9081cd38 in forkThreadForFunction
 #7   0x90021268 in _pthread_body

Thread 6:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x90525b90 in CarbonInetOperThreadFunc
 #3   0x90021268 in _pthread_body

Thread 7:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x928ec28c in JNI_CreateJavaVM_Impl
 #3   0x928ec224 in JNI_CreateJavaVM_Impl
 #4   0x928a51fc in JVM_GetClassMethodsCount
 #5   0x90021268 in _pthread_body

Thread 8:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x9285eae4 in JVM_FillInStackTrace
 #4   0x928647a0 in JVM_Send
 #5   0x9290114c in JNI_CreateJavaVM_Impl
 #6   0x928a51fc in JVM_GetClassMethodsCount
 #7   0x90021268 in _pthread_body

Thread 9:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0xa2843c38 in typeinfo name for std::bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021268 in _pthread_body

Thread 10:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x090845cc in 0x90845cc
 #9   0x090845cc in 0x90845cc
 #10  0xa2843c38 in typeinfo name for std::bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021268 in _pthread_body

Thread 11:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x92844e18 in JVM_GetClassLoader
 #4   0x92844ba4 in JVM_GetClassLoader
 #5   0x928a51fc in JVM_GetClassMethodsCount
 #6   0x90021268 in _pthread_body

Thread 12:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92903300 in JVM_InitProperties
 #5   0x92903138 in JVM_InitProperties
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021268 in _pthread_body

Thread 13:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x9288890c in JVM_StartThread
 #5   0x92876c10 in JVM_FindLoadedClass
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021268 in _pthread_body

Thread 14:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0x090845cc in 0x90845cc
 #10  0x090845cc in 0x90845cc
 #11  0x0908468c in 0x908468c
 #12  0x0908468c in 0x908468c
 #13  0xa2843c38 in typeinfo name for std::bad_exception
 #14  0x92838bdc in JVM_CurrentTimeMillis
 #15  0x92878c28 in JVM_FindClassFromClass
 #16  0x92892c90 in JVM_IsSameClassPackage
 #17  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #18  0x928787a0 in JVM_FindClassFromClass
 #19  0x928a51fc in JVM_GetClassMethodsCount
 #20  0x90021268 in _pthread_body

Thread 15:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0xa2843c38 in typeinfo name for std::bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021268 in _pthread_body

Thread 16:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0x0908468c in 0x908468c
 #10  0xa2843c38 in typeinfo name for std::bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021268 in _pthread_body

Thread 17:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0x0908468c in 0x908468c
 #10  0xa2843c38 in typeinfo name for std::bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021268 in _pthread_body

Thread 18:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0xa2843c38 in typeinfo name for std::bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021268 in _pthread_body

Thread 19:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x09086668 in 0x9086668
 #7   0x0908468c in 0x908468c
 #8   0x0908468c in 0x908468c
 #9   0x090845cc in 0x90845cc
 #10  0xa2843c38 in typeinfo name for std::bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021268 in _pthread_body

PPC Thread State:
  srr0: 0x0022de30 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x0022e628  ctr: 0x0022ef30   mq: 0x00000000
    r0: 0xfffffffb   r1: 0xbffff120   r2: 0x003e8000   r3: 0xc2ff69fe
    r4: 0x0444cb98   r5: 0xceff8cfd   r6: 0xd3445888   r7: 0xceff8cf0
    r8: 0x04afb558   r9: 0xa0220eac  r10: 0xa0220be4  r11: 0xa00042f8
   r12: 0x003e98b0  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0xbffffe90  r21: 0x04afaa10  r22: 0x00000001  r23: 0x04afbfb0
   r24: 0x003db2b8  r25: 0x021f1184  r26: 0x02038b90  r27: 0x04afbfb0
   r28: 0x00000000  r29: 0x00000000  r30: 0xc2ff69fe  r31: 0xc2ff69fe



therefore, reopening and -> networking:http
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
.
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa
You get very different stack traces.
see also my network related stack in 185082. It seems that soemthing corrupts
the stack with this crash.

based on this:
> Can you please disable the web-site icons (edit\prefern..\appareance\[] Show Web
> Site Icons and try again ?

Yes. I don't get a crash when I disable that option.
------------------------------------------------------------------------

reduping, please reopen if you still crash with tomoorows build and "web site
Icons" enabled

*** This bug has been marked as a duplicate of 184916 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
QA Contact: httpqa → tever

Updated

14 years ago
Severity: major → critical
Keywords: crash
You need to log in before you can comment on or make changes to this bug.