Infinite loop crash on system shutdown while Mozilla is reloading

VERIFIED DUPLICATE of bug 169069

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
--
critical
VERIFIED DUPLICATE of bug 169069
15 years ago
5 years ago

People

(Reporter: gonchuki, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

This is to report a bug in Mozilla that keeps the system under an infinite loop
crash. The problem arises when you close the last window of mozilla, so then it
reloads the tray icon. If you try to shutdown the system while the program is
reloading, then windows crashes giving the following report:


Kernel32.dll made an error in module <unknown> at 0177:bff766c0

Registers:
EAX= 0055003c	CS= 0177	EIP= bff766c0	EFLGS= 00010202
EBX= 00000000	SS= 017f	ESP= 00550000	EBP=   00550010
ECX= 00000000	DS= 017f	ESI= 00550108	FS=    3467
EDX= bff76859	ES= 017f	EDI= 817acc20	GS=    6000

(poorly translated to english, and copied by hand since the system is hanged at
this point)


This report is always the same, all the registers have the same value, so it is
not a random crash, it will surely crash if you follow those steps. The main
problem with this bug is that damned infinite loop crash, so after you close the
error message, it reappears once and again so the only solution to finally
shutdown the system is the reset button...

Reproducible: Always

Steps to Reproduce:
1. Close all the open Mozilla windows
2. Shutdown the system while the program is reloading itself

Actual Results:  
Infinite loop crash

Expected Results:  
Close silently without complaining

Standard instalation of Windows 98 (first edition), the problem also happens on
Win95 (maybe also on newer windows versions)
(Reporter)

Comment 1

15 years ago
i have also found the same problem while running ePSXe emulator in the
background while using Mozilla... i was playing in windowed mode with kazzuya's
video plugin, closed the window with my game walkthrough, and received the error
pointed before. It was not random since it happened twice... strange thing is
that it anyways reloads the program but other instance of mozilla gets going
with the infinite loop error.

Comment 2

15 years ago
looks like a duplicate of 169069

*** This bug has been marked as a duplicate of 169069 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.