Closed Bug 1851955 Opened 11 months ago Closed 10 months ago

Cardview shows wrong names

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115? fixed, thunderbird119? fixed)

RESOLVED FIXED
120 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird119 ? fixed

People

(Reporter: theo, Assigned: aleca)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36

Steps to reproduce:

I have 5 mailadresses with 1 domainname of the company.

Actual results:

When i've got a mail from a co-worker cardview shows my own name by al the co-workers.
in tableview it works fine.

Expected results:

cardview must show the name of my co-workers, not the name of myself

See Also: → 1847384

I would like to add that I would always expect in cards view to see the name of the sender of an email, not a recipient's. Except when this can be configured which in cards view so far is not the case.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Attachment #9353742 - Attachment description: Bug 1851955 - Use the sender instead of the correspondent as default data for the cards view. r=#thunderbird-reviewers → Bug 1851955 - Use the proper columns for the cards view depending on the selected folder. r=#thunderbird-reviewers
Duplicate of this bug: 1847384
Target Milestone: --- → 120 Branch

Pushed by vineet@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/df4fe2c144a2
Use the proper columns for the cards view depending on the selected folder. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Comment on attachment 9353742 [details]
Bug 1851955 - Use the proper columns for the cards view depending on the selected folder. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Wrong recipient name (sender/correspondent) in cards view between mail folders and feed accounts.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9353742 - Flags: approval-comm-esr115?
Attachment #9353742 - Flags: approval-comm-beta?

Comment on attachment 9353742 [details]
Bug 1851955 - Use the proper columns for the cards view depending on the selected folder. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9353742 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9353742 [details]
Bug 1851955 - Use the proper columns for the cards view depending on the selected folder. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9353742 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: