Can't send an email to a "group" of email addresses

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: George T. Adams, Assigned: racham)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

- Tried to send an email to an “All My Friends” multiple address listing, and
got a message “An error occurred while sending mail.  The mail server responded:
<All My Friends>: recipient address must contain a domain.  Please check the
message recipients and try again.”  
- All email addresses in the listing have proper domains
- This problem appears to be happening because the LIST NAME doesn’t contain a
domain (since it’s just a list name, and not an email address)
- It appears that the program is sending the list name to the server as an email
address, and the server doesn't accept it since it doesn't have a domain. 
- My workaround was to change the LIST NAME from “All My Friends” to “All My
Friends: gtadams554@earthlink.net”.  Unfortunately, this puts a double address
in the address block of the email, i.e., All My Friends:
gtadams554@earthlink.net <All My Friends: gtadams@earthlink.net>, so have to
delete the last half (the carots and everything between), and then the server
will accept the email.
- I believe you need to modify the program so that it will NOT send the address
LIST NAME as an email address.

Reproducible: Always

Steps to Reproduce:
1. Make an address group listing containing multiple email addresses
2. Address an email to that address group listing
3. Attempt to send the email.
4. You should get the error message stating that the group listing does not
contain a domain.

Actual Results:  
Got error message “An error occurred while sending mail.  The mail server
responded: <All My Friends>: recipient address must contain a domain.  Please
check the message recipients and try again.”  

Expected Results:  
List name should not have been sent as an email address.
(Reporter)

Comment 1

15 years ago
Further update.  Apparently this problem occurred because I was using the 
address book I imported from Netscape 4.79.  Yesterday I dumped that address 
book, imported it again from Netscape 4.79 as a different address book name, and 
then clicked and dragged each address from the imported address book into 
"Personal Address Book" one at a time.  Then I built a completely new "All My 
Friends" mail list in "Personal Address Book" and clicked/dragged the addesses 
to it from the main listing.  After having done all that, I tried to send an 
email to the newly built "All My Friends" mail list, and it worked just fine.  I 
have no idea why it won't send the email to the "All My Friends" mail 
list in the imported address book.  Hmmmmmm.   

Comment 2

14 years ago
WFM with Moz 1.7.3 on WinXP. Marking fixed.
Reporter, if you still see this problem with the latest nightly, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 3

14 years ago
No bug / patch specified as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.