Composer turns .css and .ram files to html (should remain text files)

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: John Coonrod, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Linux
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Mozilla can open a css file and pass it to composer to be edited, but on the way
it converts it to html. composer should be able to edit text files as text files.

Reproducible: Always

Steps to Reproduce:
1.open a css file
2.publish it
3.

Actual Results:  
the .css file is converted into an html file

Expected Results:  
leave it as a text file

Comment 1

16 years ago
John Coonrod--Can you provide example files that cause this?  A minimal testcase
would be great.  Perhaps Composer isn't recognizing the css file as a text file?
 Do you know if this is a regression?  Did it work in mozilla 1.0 or 1.1?  Does
it work if you save the file locally instead of publishing it?
Summary: Composer turns .css and .ram files to html → Composer turns .css and .ram files to html (should remain text files)
(Reporter)

Comment 2

16 years ago
Any css file I open on the web seems to do this. For example, open
http://www.thp.org/hp.css from composer and you'll see it happen. I have no idea
if this is a regression - but composer is definitely converting these files to
html upon entry - simply look at the html tab. The least it should do is check
file extensions!

Comment 3

16 years ago
-->composer
Assignee: syd → composer

Updated

16 years ago
Keywords: nsbeta1
(Reporter)

Comment 4

16 years ago
Is anything happening with this bug?

Updated

16 years ago
Keywords: helpwanted

Comment 5

16 years ago
can someone confirm this bug? is it linux-specific?
QA Contact: sujay → petersen

Updated

14 years ago
Keywords: nsbeta1
Product: Browser → Seamonkey

Comment 6

13 years ago
I can reproduce the problem with Mozilla 1.2.1, but not with 1.3 or anything
since then.

resolving WORKSFORME.  reopen if this is still a problem with recent builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.