Closed Bug 1852855 Opened 10 months ago Closed 8 months ago

getting new messages in subfolders no longer highlights the folder

Categories

(Thunderbird :: Theme, defect)

Thunderbird 115
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1854377

People

(Reporter: yvong, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Steps to reproduce:

After updating from 102.xx to the latest version v115.2.0 there is a change in displaying new messages in subfolders. Until with the previous version, it was so that after receiving all new messages and automatic filtering in the respective subfolders, the associated folders were highlighted by light, so that one was able to see in which subfolders the new messages are located. Unfortunately, in the current version (v115.2.0) it is not like that anymore. There is a round, blue icon with a number (equal to the amount of new messages) next to the main folder, but it disappears as soon as you click on its main folder to go to the subfolder. In the subfolders below the main folder, no new messages are marked, so you can't see where the new messages are. So you would have to "laboriously" and in the worst case look in all subfolders to see if the new messages have been moved there. This is not optimal. In the settings I can't find the right thing to do. Maybe someone knows a setting option or solution. For clarification:

  • Main folder in the theme tree: Shops, Private, Company, etc.
  • Subfolders under the main folder "Shops": Amazon, Schrauben.de, Karstadt, etc.
  • in the subfolder of "Amazon": received messages, sent messages

I have about 30 main folder entries and there can sometimes be up to 100 subfolder entries each. Looking for where the new messages are located is not practical.

I have another issue where I have not yet found an optimal solution to this. To the topic tree I have set up two virtual folders (one for an IMAP account and one for a POP3 account) to facilitate a search for messages. Unfortunately, as a result of a search always shows me only the very last subfolder (storage location) as a result. And this is inevitably always "received messages".... for me. Again, I can't immediately see where the message I'm looking for is hidden in the topic tree. Also not optimal. Better would be an indication of the complete path as a result of a search. This issue can be seen in all versions of Thunderbird. Is there a solution for this ? The separation of the messages with me between "received" and "sent" messages is "mandatory". Only in this way I can quickly see when what was written and what replies came at what time.

Actual results:

Addendum on the subject of displaying new messages in the subfolders:

there is probably a bug in the new version (v115.2.0). After closing and reopening Thunderbird, the new messages also show up in the subfolders in the highlighted context. I.e. they are also visible in the subfolders. Also numbers are shown there, how many new messages are there. So in principle it should still work like this, but obviously due to a bug the new messages are only clearly marked in all folders incl. subfolders after a restart.

My guess:
it contains a problem in the automatic filter processing after e-mail receipt.

Expected results:

After receiving the messages and after automatic filtering, all folders, including their subfolders, where the new messages are placed, should be marked.

The search function should always display the complete path as a result and not the very last (sub)folder. Otherwise it is not possible to find the mail you are looking for.

Component: Filters → Folder and Message Lists
Keywords: regression
Whiteboard: [Supernova3p]

Regarding your second issue, that's already been requested some time ago in bug 727821.

See Also: → 727821
See Also: 727821

Bug 522768 is a better match.

See Also: → 522768
Component: Folder and Message Lists → Theme
Summary: Viewing new messages in subfolders → getting new messages in subfolders no longer highlights the folder
Duplicate of this bug: 1857436
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Duplicate of bug: 1854377
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.