Closed Bug 1852940 Opened 2 years ago Closed 2 years ago

The Feed URL is not a valid feed.

Categories

(Thunderbird :: Untriaged, defect)

Thunderbird 119
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: DenIrenicus, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/117.0

Steps to reproduce:

I try to add the site to the RSS feed and get the error:
"The Feed URL is not a valid feed."
RSS url: https://dentnt.trmw.ru/rss

Actual results:

Cant add side because of error "The Feed URL is not a valid feed."
RSS validators and Firefox plugins opens this feed correctly.

Expected results:

A week ago all feeds work well in Thunderbird. The site is based on WordPress RSS engine.

https://dentnt.trmw.ru/rss works for my in 115 and Daily. Was there a temporary issue with the publisher?

Yes, now i can get the messages. But why first time there were validation errors?
Now I cant add the blog from live journal: https://nkrichevsky.livejournal.com/rss
Thunderbird gives me the error:
nkrichevsky.livejournal.com uses an invalid security certificate.

Is it Thunderbird validator errors? Is there a way to add an option to skip validation? Could this option be added in future releases?

Maybe you got a captive portal? Or maybe the

That feed works for me.
If you got an invalid certification, either you really got MITM attacked, or the server was misconfigured for a while.

Nothing thunderbird could do about these. There would be no point skipping validation - as the feed would not work anyway.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID

Strange, but now I get same the error with "https://nkrichevsky.livejournal.com/rss".
First feed url is added and working...

Don't know how to edit comment.
The error: "The Feed URL is not a valid feed."

Attached image 2023-09-14_23-17-17.png
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

If we don't get proper content, there's not much we can do. The issues seem to be with your network or server side.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INVALID

Excuse me, but the problem is in internal VALIDATOR, not in RSS article. I can use Firefox extension Feedbro - RSS Feed Reader:
https://addons.mozilla.org/en-GB/firefox/addon/feedbroreader/
It opens these RSS feeds without any problem. So I can tell, that if even there are any mark up errors, they are not critical and these articles could be read. And this bug is not the one, where we complain to Thunderbird validator engine. There are a lot of posts on Reddit. If you dont wish to solve validator problem, please add the hidden setting to skip validation. I repeat - some time ago these RS feeds works well without any complains from Thunderbird!

I had tried both feeds and they work for me in Thunderbird. Check your system/network.

I can open these feeds too. They are works well with Firefox, or Edge. That's why its strange, that validator (validator.w3.org) tells:

Sorry
This feed does not validate

https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fnkrichevsky.livejournal.com%2Frss

And my Thunderbird does not add this url because of the validator results, no?

The validator results are just there to help.
Thunderbird doesn't use it because it receives something it can't handle.
Maybe it's getting served something else. Open the DevTools network tab and see what it gets sent.

The problem was with default DNS on my router - there was set Family protection AdGuard DNS.
I set custom DNS in settings:
https://unfiltered.adguard-dns.com/dns-query
But this one blocks this url too:
"We blocked this page because of parental filter restrictions.
You're trying to reach a website listed by AdGuard as inappropriate for kids. If you’re an adult, you can switch off Parental control in the settings or add this website to the allowlist."
That weird, because this DNS is marked as unfiltered. It seems something is broken in AdGuard side.

The problem was solved, when I changed it to default Ad free DNS.
Settings -> General -> Network & Disk Space -> Connection -> Settings... -> Enable DNS-over-HTTPS
https://dns.adguard-dns.com/dns-query

So you were right - the problem not in TB.
Thanks for the help!

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: