pizzahut.fr - coupons on the right do not appear in Mozilla, Bad Sniffing...

RESOLVED FIXED

Status

Tech Evangelism Graveyard
French
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Tristan Nitot, Unassigned)

Tracking

Details

(Whiteboard: [havecontact][havefix][bug248549notfixed], URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

16 years ago
Tested with Mozilla 1.3a

1 - visit http://www.pizzahut.fr/ (with Flash Player installed)
2 - observe that no coupons are shown on the right hand side of the home page.
3 - in the JavaScript console : Error: document.layers has no properties /
Source File: http://www.pizzahut.fr/coupon.php3 / Line: 19

In that file : 
if (navigator.appName ==
"Netscape"){layerStyleRef="layer.";layerRef="document.layers";styleSwitch=""}
else {layerStyleRef="layer.style.";layerRef="document.all";styleSwitch=".style"}
ns = (document.layers)? true:false
ie = (document.all)? true:false

Contact information
their web agency is K-agency
20 rue des jardins
92601 asnieres cedex
01 41 11 65 65

also, in the "nous contacter" page : service.clients@tricon-yum.com
(Reporter)

Updated

16 years ago
Whiteboard: [havecontact]
Summary: pizzahut.fr : coupons on the right do not appear in Mozilla, Bad Sniffing... → pizzahut.fr - coupons on the right do not appear in Mozilla, Bad Sniffing...
mass moving old french europe west bugs to the new french component...
Assignee: nitot → french
Component: Europe: West → French
QA Contact: brantgurganus2001 → french

Comment 2

15 years ago
Created attachment 125776 [details]
New file for http://www.pizzahut.fr/coupon.php3

Right frame had detection between msie (document.all) and netscape 4.x
(document.layers).

Added DOM alternative.
Tested on Firebird 0.6 and Mozilla Gecko/20030605 (1.5a branch)

Updated

15 years ago
Whiteboard: [havecontact] → [havecontact][havefix][PROPRIETARY-JS]
http://www.pizzahut.fr/coupon.php3 is 404. site seems to be working for me...

Comment 4

14 years ago
ordering doesn't work: http://www.pizzahut.fr/page_contenu.php?type=carte
clicking on ok -> JS console shows:

Error: carte is not defined
Source File: http://www.pizzahut.fr/page_contenu.php?type=carte
Line: 139
OS: Windows XP → All
Hardware: PC → All
yup, new problem. will work on that. is contact info still ok?
Whiteboard: [havecontact][havefix][PROPRIETARY-JS] → [havecontact]

Updated

14 years ago
Attachment #125776 - Attachment is obsolete: true
Ok, the problem is that they are using the form's name attribute as a javascript
variable. IE allows this, we don't.

In http://www.pizzahut.fr/page_contenu.php?type=carte, line 139, instead of
carte.submit()
they need to use
document.forms['carte'].submit();

This should work properly in every browser.
They also need to appy the same fix for other pages too.
For instance in http://www.pizzahut.fr/page_contenu.php?type=inscription_promos,
line 43, they should replace
inscription.submit();
with
document.forms['inscription'].submit();

Anyone willing to contact them with this fix, please include a link to
http://www.openweb.eu.org/articles/validation_formulaire/ , which gives more
details on the problem.
Whiteboard: [havecontact] → [havecontact][havefix]

Updated

14 years ago
Whiteboard: [havecontact][havefix] → [havecontact][havefix][bug248549notfixed]

Comment 7

14 years ago
ecommerce WFM anyway
Yup, they changed their code a bit and it fixes it.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.