Closed Bug 18538 Opened 21 years ago Closed 21 years ago

[crash] Apprunner won't start after Mac restart

Categories

(SeaMonkey :: General, defect, P3, critical)

PowerPC
Mac System 8.6
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: mpt, Assigned: don)

Details

Build:
    1999-11-09, and every earlier build which I have tried (I've been downloading
    builds occasionally since M10).

To reproduce:
    Download a nightly build. Repeat {start apprunner; quit Apprunner} as often
    as desired. Restart the computer. Try to start Apprunner.

What should happen:
    Apprunner should start up as usual.

What happens:
    The Mozilla splash screen appears for about three seconds, then goes away,
    and nothing else happens. Apprunner has quit.

I wouldn't be surprised if this was something specific to my system, but that
doesn't mean it shouldn't be fixed. And since I can't start Apprunner, I can't
turn on any of the debugging features. :-)
Summary: Apprunner won't start after Mac restart → [crash] Apprunner won't start after Mac restart
I'm about to be distanced from the Macs on which I test Mozilla by about 428
kilometres, and I will remain so until mid-February. So I'm sorry I won't be able
to help troubleshoot this bug.
QA Contact: leger → paulmac
paulmac, I have not had this problem with OS 8.51 on a G3.  Has anyone on your
team?
Assignee: leger → don
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
mpt, are you still around? Please try this with an m11 build from
http://www.mozilla.org/projects/seamonkey/release-notes/

But first, delete the Mozilla Registry from your Preferences directory and your
Documents | Mozilla directory, and be sure to install in a clean directory.

Marking worksforme. Please re-open is you still see this after a clean install.
Thanks.
Yeah, I'm still here, but -- as noted above -- stuck on a Windows machine, with
not a Mac in sight. <sigh/>

On the Macs at university (which I used to test Mozilla), I was not able to
delete the Mozilla Registry file -- which I suspected may be the cause of the
bug -- because the Preferences folder (the whole of the System folder, in fact)
was protected by MacPrefect. This may be the indirect cause of the bug -- I
don't see why, though, since Mozilla is quite capable of writing the original
version of the Mozilla Regisry file into the Preferences folder when first run.

So ... I don't know the mechanics of Mac I/O (or of MacPrefect, for that
matter), but is Mozilla pretending to be the Finder or something like that when
it tries to update the file (but not when it creates the file to begin with)?
That might cause MacPrefect to block the update. But even then, Mozilla should
at least put up an error message saying what's wrong; it shouldn't just
silently quit.
mpt, I don't know the answer to your Mozilla Registry question on the mac.
cc'ing a couple mac people who may be able to answer your question.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.