If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla slows and then hangs when opening multiple articles in separate windows

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Douglas Godfrey, Assigned: asa)

Tracking

({hang})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

Similar to Bug#: 173633

After opening 6-8 articles from "The Inquirer" web site,
Mozilla slows down to the point of uselessness. CPU is 
at 80% on 2 processors (160% CPU utilization). Mozilla
takes up to 30 seconds to process each mouse click.



Reproducible: Always

Steps to Reproduce:
1. goto http://www.theinquirer.net/
2. Click/hold mouse on an article link and select "open in new window"
3. do step #2 6-8 times
4. Mozilla hangs

Actual Results:  
Mozilla hangs

Expected Results:  
Mozilla should not hang.

Clicking multiple times on the close widgit of the frontmost 
Mozilla window eventually was noticed, but, instead of closing 
just the front window, ALL windows closed and then Mozilla Quit.

This is probably caused by the Inquirer using a Java applet to 
display an animated graphic of about 80x200 pixels.

Mozilla is probably attempting to run 8 copies of the applet
and then clipping the output of the windows where the graphic
is hidden.

When multiple open windows use the same applet, only one copy
should run at any one time. Whichever copy is associated with
the frontmost window should run and all others should be suspended.

Any time the window area used by an applet is completely hidden
by other windows, the applet should be suspended until it's area
is un-hidden.

Comment 1

15 years ago
I'm seeing a lot browser hangups since the new Moz/Gre build on 1/22.  I went to
Redhat.com and images didn't load, browser hung no other activity, closed
browser and it launches the Turbo mode, but two mozilla.exe's are present. 

Updated

15 years ago
Severity: normal → critical
Keywords: hang
Summary: Mozilla slows and then hangs when opening multiple articles in seperate windows → Mozilla slows and then hangs when opening multiple articles in separate windows

Comment 2

15 years ago
WFM 1.3b/OS X

Douglas, are you still seeing this behavior with recent build?

Comment 3

14 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.

Comment 4

14 years ago
resolving WFM based on previous reports without objection
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.