Closed Bug 1854444 Opened 7 months ago Closed 4 months ago

[meta] Investigate elements that are failing Tier 2 a11y_checks for Bookmarks & History

Categories

(Firefox :: Bookmarks & History, task, P3)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: ayeddi, Unassigned)

References

Details

(Keywords: access, meta)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, the failing tests were failed-if by the bug 1854443.

This task is to track the investigation into the reasons each of these tests failed and to be able to backtrack these tests once they're resolved.

Individual bugs to block the following bugs

  1. (all) this meta bug
  2. (Interactive elements must be labeled / Node is enabled but disabled via the accessibility API) bug 1854227 (a11y_checks_labeled)
  3. (Node is not accessible via accessibility API / Node is not focusable via the accessibility API / Node is enabled but disabled via the accessibility API) Bug 1848394 (a11y_checks_focusable)

Tests affected:

browser/components/places/tests/browser/browser_bookmarkProperties_xulStore.js	Interactive elements must be labeled	bookmarks-view	tree	sidebar-placesTree
browser/components/places/tests/browser/browser_sidebar_bookmarks_telemetry.js	Interactive elements must be labeled	bookmarks-view	tree	sidebar-placesTree
browser/components/places/tests/browser/browser_sidebar_history_telemetry.js	Interactive elements must be labeled	historyTree	tree	sidebar-placesTree
browser/components/places/tests/browser/browser_sidebar_open_bookmarks.js	Interactive elements must be labeled	bookmarks-view	tree	sidebar-placesTree
browser/components/places/tests/browser/browser_sidebarpanels_click.js	Interactive elements must be labeled	bookmarks-view	tree	sidebar-placesTree
browser/components/places/tests/browser/browser_sidebarpanels_click.js	Interactive elements must be labeled	historyTree	tree	sidebar-placesTree

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

New test failure: (Try):

FAIL	browser/components/places/tests/browser/browser_bookmarkProperties_xulStore.js	Interactive elements must be labeled	bookmarks-view	tree	sidebar-placesTree
Depends on: 1866902
Depends on: 1867053

Since all the failing a11y_checks for Bookmarks & History were resolved, I am closing this meta bug as fixed.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.