Closed Bug 1854537 Opened 10 months ago Closed 4 months ago

[meta] Investigate elements that are failing Tier 2 a11y_checks for Customizable UI

Categories

(Firefox :: Settings UI, task, P3)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: ayeddi, Assigned: ayeddi)

References

(Depends on 1 open bug)

Details

(Keywords: access, meta)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, the failing tests were failed-if by the bug 1854536.

This task is to track the investigation into the reasons each of these tests failed and to be able to backtrack these tests once they're resolved.

Individual bugs to block the following bugs

  1. (all) this meta bug
  2. (Interactive elements must be labeled / Node is enabled but disabled via the accessibility API) bug 1854227 (a11y_checks_labeled)
  3. (Node is not accessible via accessibility API / Node is not focusable via the accessibility API / Node is enabled but disabled via the accessibility API) Bug 1848394 (a11y_checks_focusable)

Tests affected:

Result	Path	Error	Element ID	Element tagName	Element className
FAIL	browser/components/customizableui/test/browser_940307_panel_click_closure_handling.js	Node is not focusable via the accessibility API	browser_946166_button_disabled	toolbarbutton	
FAIL	browser/components/customizableui/test/browser_981418-widget-onbeforecreated-handler.js	Interactive elements must be labeled	test-981418-widget-onbeforecreated	toolbarbutton	toolbarbutton-1 chromeclass-toolbar-additional
FAIL	browser/components/customizableui/test/browser_create_button_widget.js	Interactive elements must be labeled	test_dynamically_created_button	toolbarbutton	toolbarbutton-1 chromeclass-toolbar-additional
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_keyboard.js	Interactive elements must be labeled	moz-toggle-button	button	toggle-button
FAIL	browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	browser/components/customizableui/test/browser_synced_tabs_menu.js	Node is not accessible via accessibility API	PanelUI-remotetabs-connect-device-button	toolbarbutton	PanelUI-remotetabs-button

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

Depends on: 1858041
See Also: → 1857056
See Also: → 1848909

The bug 1848909 is expected to resolve the following test failure:
FAIL browser/components/customizableui/test/browser_synced_tabs_menu.js Node is not accessible via accessibility API PanelUI-remotetabs-connect-device-button toolbarbutton PanelUI-remotetabs-button

Depends on: 1862087
Depends on: 1863815
Depends on: 1864240
Depends on: 1877602
Depends on: 1877603

Closing the meta bug since all the failing a11y-check instances were investigated and the only one bug 1864240 (with low severity) remains unresolved and retains fail-if notation.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.