Closed Bug 1854636 Opened 7 months ago Closed 7 months ago

Temporarily disable some Tier 2 a11y_checks for Settings UI

Categories

(Firefox :: Settings UI, task, P3)

task

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: ayeddi, Assigned: ayeddi)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved. A separate task to investigate the failed Tier 2 a11y_checks will be filed for an appropriate component.

Tests affected:

FAIL	browser/components/preferences/tests/browser_application_xml_handle_internally.js	Interactive elements must be labeled		menulist	actionsMenu
FAIL	browser/components/preferences/tests/browser_applications_selection.js	Node is not accessible via accessibility API	typeColumn	treecol	
FAIL	browser/components/preferences/tests/browser_applications_selection.js	Node is not accessible via accessibility API	actionColumn	treecol	
FAIL	browser/components/preferences/tests/browser_cookies_exceptions.js	Node is not accessible via accessibility API	siteCol	treecol	
FAIL	browser/components/preferences/tests/browser_engines.js	Node is not accessible via accessibility API	engineChildren	treechildren	
FAIL	browser/components/preferences/tests/browser_filetype_dialog.js	Interactive elements must be labeled		menulist	actionsMenu
FAIL	browser/components/preferences/tests/browser_localSearchShortcuts.js	Node is not accessible via accessibility API	engineChildren	treechildren	
FAIL	browser/components/preferences/tests/browser_pdf_disabled.js	Interactive elements must be labeled		menulist	actionsMenu
FAIL	browser/components/preferences/tests/browser_permissions_dialog.js	Node is not accessible via accessibility API	statusCol	treecol	
FAIL	browser/components/preferences/tests/browser_permissions_dialog.js	Node is not accessible via accessibility API	siteCol	treecol	
FAIL	browser/components/preferences/tests/browser_searchDefaultEngine.js	Interactive elements must be labeled	defaultEngine	menulist	
FAIL	browser/components/preferences/tests/browser_searchDefaultEngine.js	Interactive elements must be labeled	defaultPrivateEngine	menulist	
FAIL	browser/components/preferences/tests/browser_subdialogs.js	Node is not accessible via accessibility API		label	dialogTitle
FAIL	browser/components/preferences/tests/browser_subdialogs.js	Node is not accessible via accessibility API	dialogTemplate	vbox	dialogOverlay dialogOverlay-171
FAIL	browser/components/preferences/tests/siteData/browser_siteData_multi_select.js	Node is not accessible via accessibility API	hostCol	treecol	
FAIL	browser/components/preferences/tests/siteData/browser_siteData3.js	Node is not accessible via accessibility API	usageCol	treecol	
FAIL	browser/components/preferences/tests/siteData/browser_siteData3.js	Node is not accessible via accessibility API	hostCol	treecol	
FAIL	browser/components/preferences/tests/siteData/browser_siteData3.js	Node is not accessible via accessibility API	cookiesCol	treecol	

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

Blocks: 1854637

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved.

Related bugs:

  • Disabling tests: meta bug 1848402
  • Investigation and remediation for components with disabled tests: meta bugs 1848394 and 1854227, Settings UI-specific meta bug 1854637
  • Explore capturing click events for a11y_checks: bug 1692110

Depends on D188990

Attachment #9354620 - Attachment description: WIP: Bug 1854636 - Temporarily disable some Tier 2 a11y_checks for Settings UI. r=mstriemer,Gijs,mossop,mconley,Jamie → Bug 1854636 - Temporarily disable some Tier 2 a11y_checks for Settings UI. r=mstriemer,Gijs,mossop,mconley,Jamie
Attachment #9354620 - Attachment description: Bug 1854636 - Temporarily disable some Tier 2 a11y_checks for Settings UI. r=mstriemer,Gijs,mossop,mconley,Jamie → Bug 1854636 - Temporarily disable some Tier 2 a11y_checks for Settings UI. r=Gijs,#settings-reviewers,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36460a147684
Temporarily disable some Tier 2 a11y_checks for Settings UI. r=Jamie,Gijs,settings-reviewers
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Attachment #9354620 - Attachment description: Bug 1854636 - Temporarily disable some Tier 2 a11y_checks for Settings UI. r=Gijs,#settings-reviewers,Jamie → Bug 1854636 - Temporarily fail-if some Tier 2 a11y_checks for Settings UI. r=Gijs,#settings-reviewers,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12cca08b91fe
Temporarily fail-if some Tier 2 a11y_checks for Settings UI. r=Jamie,Gijs,settings-reviewers
Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
See Also: → 1848397
See Also: → 1872739
See Also: → 1872743
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: