mismatched alloc/delete in qt/nsWidget.cpp

RESOLVED FIXED

Status

Core Graveyard
Ports: Qt
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Biesinger, Assigned: Biesinger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

will attach a patch in a second
Created attachment 109345 [details] [diff] [review]
patch

timeless, could you review?

fwiw, the valgrind message was:

==2554== Mismatched free() / delete / delete []
==2554==    at 0x4003B1A3: __builtin_vec_delete (vg_clientfuncs.c:214)
==2554==    by 0x45D031D7: nsWidget::SetTitle(nsString const &)
(../../../../widget/src/qt/nsWidget.cpp:598)
==2554==    by 0x80614D3: nsBrowserWindow::SetTitle(unsigned short const *)
(../../../../webshell/tests/viewer/nsBrowserWindow.cpp:431)
==2554==    by 0x808548B: nsWebBrowserChrome::SetTitle(unsigned short const *)
(../../../../webshell/tests/viewer/nsWebBrowserChrome.cpp:367)
==2554==    Address 0x4626A1F0 is 0 bytes inside a block of size 19 alloc'd
==2554==    at 0x4003ADE2: malloc (vg_clientfuncs.c:100)
==2554==    by 0x4052846D: PR_Malloc
(../../../../../nsprpub/pr/src/malloc/prmem.c:433)
==2554==    by 0x404714AF: nsMemoryImpl::Alloc(unsigned int)
(../../../xpcom/base/nsMemoryImpl.cpp:320)
==2554==    by 0x404B3E73: nsMemory::Alloc(unsigned int)
(../../../xpcom/glue/nsMemory.cpp:87)

Updated

15 years ago
Attachment #109345 - Flags: review+

Comment 2

15 years ago
*** Bug 184610 has been marked as a duplicate of this bug. ***
Checking in nsWidget.cpp;
/cvsroot/mozilla/widget/src/qt/nsWidget.cpp,v  <--  nsWidget.cpp
new revision: 1.21; previous revision: 1.20
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Component: Browser-General → Ports: Qt
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.