Progressmeter is invisible when mode="undetermined" in Classic Theme

RESOLVED WORKSFORME

Status

Core Graveyard
Skinability
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Matthew Wilson, Assigned: Matthias Bockelkamp)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

In Mozilla 1.3a (but not in 1.2.1), a progressmeter with mode="undetermined"
does not display anything in the Classic Theme.

Reproducible: Always

Steps to Reproduce:
1. Load a document with a progressmeter with mode="undetermined" in the Classic
Theme.

Actual Results:  
No element was visible.

Expected Results:  
A scrolling progress meter should be displayed.
(Reporter)

Comment 1

15 years ago
Created attachment 109348 [details]
XUL demonstration file containing a progressmeter

Comment 2

15 years ago
hope this is related, if not I apologize; it also applies to the classic theme:
after upgrading from 1.2.1 to 1.3a (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.3a) Gecko/20021216) I discovered that the "scrolling progressmeter"
that used to show up if Mailnews was sending the login/password to the
Mailserver  is missing.
Furthermore: the standard progressmeter (e.g. while loading a webpage) has lost
its discreet gray color and turned dark blue. Also: the standard progressmeter
in the download-progress dialog has lost its "boundaries".

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

14 years ago
Assigning to me.
Assignee: andreww → mbockelkamp
Status: ASSIGNED → NEW
(Assignee)

Comment 4

14 years ago
Created attachment 131426 [details] [diff] [review]
Patch
(Assignee)

Updated

14 years ago
Attachment #131426 - Flags: superreview?(hyatt)
Attachment #131426 - Flags: review?(hyatt)
(Assignee)

Comment 5

14 years ago
Created attachment 131427 [details] [diff] [review]
Patch v2

I just saw this is also necessary for Macintosh (but I cannot test it).
(Assignee)

Updated

14 years ago
Attachment #131426 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #131427 - Flags: superreview?(hyatt)
Attachment #131427 - Flags: review?(hyatt)
(Assignee)

Updated

14 years ago
Attachment #131426 - Flags: superreview?(hyatt)
Attachment #131426 - Flags: review?(hyatt)
(Assignee)

Updated

14 years ago
Attachment #131427 - Flags: review?(hyatt) → review?(cbiesinger)
Comment on attachment 131427 [details] [diff] [review]
Patch v2

please don't ask me for review on general ui bugs. try neil.

that said, can you explain why this fixes anything? Are you sure your patch
causes no CSS syntax error?
Attachment #131427 - Flags: review?(cbiesinger) → review?(neil.parkwaycc.co.uk)

Comment 7

14 years ago
Comment on attachment 131427 [details] [diff] [review]
Patch v2

>RCS file: /cvsroot/mozilla/themes/classic/global/win/progressmeter.css,v
>-  -moz-appearance: progressbar;
This styles is needed for Windows XP theme support for normal progressmeters.
Unfortunately the appearance overrides the background image, which is
unexpected.
Attachment #131427 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 8

14 years ago
Note to self: Caused by Bug 115748
(Assignee)

Updated

14 years ago
Attachment #131427 - Flags: superreview?(hyatt)

Comment 9

14 years ago
The "Smoke" theme also doesn't work for undetermined progress meters... I just
tried Alice Corbin's mega XUL test page
(http://www.hevanet.com/acorbin/xul/top.xul) and the undetermined progress meter
ain't there.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040428
(Assignee)

Comment 10

13 years ago
There is a working progressmeter for mode="undetermined" for some time now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.