Closed Bug 1854810 Opened 7 months ago Closed 7 months ago

Only last Message List column expands when window resized

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1850893

People

(Reporter: bugs, Unassigned)

Details

Attachments

(2 files)

Attached image Maximized.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Steps to reproduce:

1.) Set the Message List display to "Table View".
2.) Expand the width of the Thunderbird application window.

Actual results:

Only the last column (date by default) expands to fill in the blank space, causing a large amount of white space to appear.

Expected results:

All columns in the Message List and the Message Pane itself should expand equally.

This is very apparent when taking a smaller window and maximizing it, or moving from, say, a laptop screen with Thunderbird already maximized to a higher resolution external monitor.

The Message List's "Cards View" also has this problem, but the center of the "column" is where the large white space appears since its textual elements are both left aligned (e.g., subject) and right aligned (e.g., date). In that case the Message Pane still does not resize itself at all.

The graceful expansion of all Message List and Message Pane worked properly in the last stable pre-Supernova version (102.5.1) and before.

I'm using Thunderbird 115.2.3, though this problem remains in the current nightly release of 119.0a1 (2023-09-23). Tested on Kubuntu 23.04.

Component: Untriaged → Mail Window Front End

Indeed, we're unfortunately aware of this as the currently table layout doesn't easily offer a solution for graceful accordion % expansion of columns.
We will tackle this in bug 1850893, with a rebuilt semantic structure.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1850893
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: