Roman text on Japanese pages overlap and render outside the page area

RESOLVED DUPLICATE of bug 143557

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 143557
15 years ago
15 years ago

People

(Reporter: Kim Ahlström, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021214 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021214 Chimera/0.6+

Browsers: Chimera (Build ID: 2002121404) and Mozilla (Mozilla/5.0 (Macintosh; U;
PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212) (including earlier versions of
these browsers).

Problem: Roman text on Japanese pages either overlap other roman text in
different style or render outside the page area (although not visible outside).

Example pages:
http://rut.org/cgi-bin/j-e/sjis/dosearch?sDict=on&T=nyuuryoku&L=J&H=PS&NOFUZZY=on&WC=none
Blue text on second line clearly overlaps beige text. Red semicolons on the
lines below japanese search results overlap beige text. (Page is Shift_JIS)
http://www.kanjiclinic.com/kc29final.htm
Text is rendered (although not visible) outside the page area. This chops of and
hides words close to the right page border. (Page is unknown character set)
http://www.csse.monash.edu.au/cgi-bin/cgiwrap/jwb/wwwjdic?1C
Bold text on second line clearly overlaps normal text. (Page is EUC-JP)

Common for all example pages: When text is selected, the actual graphic
representation of the selection is to narrow and doesn't include all the text.
Best seen when entire lines are selected. However, if you copy the selected
text, all the text is copied, even the non-visibly-selected text.

Reproducible: Always

Steps to Reproduce:
1. Launch
2. Go to URLs described in Details-text.
3. Notice anomalies discussed in Details-text.

Actual Results:  
Roman text is overlapping or drawn outside page area.

Expected Results:  
Not draw the roman text overlapping or outside the page area.

OS: MacOS X 10.2.2
Unknown if problem exists on other OS:s or platforms.
(Reporter)

Comment 1

15 years ago
Also, as can be seen on the following Shift JIS page, underlined roman text
links' underline is shorter than the actual text.
http://members.tripod.co.jp/sa_yoshi/ocha/nihongo4AB2001.html

Comment 2

15 years ago
dup of Bug 143557.

Comment 3

15 years ago
Resolving dup per comment 2.

*** This bug has been marked as a duplicate of 143557 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.