Closed Bug 1855065 Opened 5 months ago Closed 5 months ago

Edit as new, reply or redirect multiple messages at once is no longer possible.

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115? fixed, thunderbird119? fixed)

RESOLVED FIXED
120 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 ? fixed
thunderbird119 ? fixed

People

(Reporter: fischer, Assigned: welpy-cw)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

Steps to reproduce:

Select multiple messages in the message list window. Attempt to edit them as new using the main menu Message -> Edit as New Message

In TB 102 this functionality existed and it no longer exists.

This does NOT reproduce in version 102

Blocks: sn-msglist
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alessandro)
Keywords: regression
Summary: When selecting multiple messages Message -> Edit as New Message no longer works → Select multiple messages, Message -> Edit as New Message no longer works
Whiteboard: [Supernova3p]

This will be solved in bug 1853558, since this also affects editing multiple drafts or templates and the code is shared.

Status: NEW → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1853558
Flags: needinfo?(alessandro)
Resolution: --- → DUPLICATE

Actually, "Edit as New" for multiple messages was not covered in bug 1853558, as I've just realized. Since "Reply" and "Redirect" also don't work anymore (while "Forward" does in both flavors), I suggest the following fix, which restores the functionality.

See also https://connect.mozilla.org/t5/discussions/things-that-don-t-work-any-more/m-p/40706 and https://al-howardknight-net.translate.goog/?STYPE=msgid&MSGI=%3Cko3411FkehlU1@mid.individual.net%3E&_x_tr_sch=http&_x_tr_sl=auto&_x_tr_tl=en&_x_tr_hl=en&_x_tr_pto=wapp for user stories.

Assignee: nobody → h.w.forms
Status: RESOLVED → REOPENED
No longer duplicate of bug: 1853558
Regressed by: 1735119
Resolution: DUPLICATE → ---
See Also: → 1853558
Summary: Select multiple messages, Message -> Edit as New Message no longer works → Edit as new, reply or redirect multiple messages at once is no longer possible.
Attachment #9356639 - Attachment description: Bug 1855065 - Re-enable compose actions for multiple messagesat once. r=#thunderbird-front-end-reviewers → Bug 1855065 - Re-enable compose actions for multiple messages at once. r=#thunderbird-front-end-reviewers
Target Milestone: --- → 120 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1709bda65a56
Re-enable compose actions for multiple messages at once. r=aleca

Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED

Comment on attachment 9356639 [details]
Bug 1855065 - Re-enable compose actions for multiple messages at once. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): 1735119
User impact if declined: See summary. Breaking plausible workflows of people.
Risk to taking this patch (and alternatives if risky): Low, backed by automated tests.

Attachment #9356639 - Flags: approval-comm-esr115?
Attachment #9356639 - Flags: approval-comm-beta?

Comment on attachment 9356639 [details]
Bug 1855065 - Re-enable compose actions for multiple messages at once. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9356639 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9356639 [details]
Bug 1855065 - Re-enable compose actions for multiple messages at once. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9356639 - Flags: approval-comm-esr115? → approval-comm-esr115+
Regressions: 1866819
You need to log in before you can comment on or make changes to this bug.