Absolutely positioned span makes text in <input> disappear

RESOLVED DUPLICATE of bug 182107

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED DUPLICATE of bug 182107
16 years ago
16 years ago

People

(Reporter: aep, Assigned: roc)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

When going to investor.com main page and trying to type text into "get quote"
box, it is blank. 

Reproducible: Always

Steps to Reproduce:
1. Go to Investor.com
2. Type any text into "get quote" box
3. Any text you type will appear blank.

Actual Results:  
Text typed didn't appear. Maybe there is a problem with the font color??

Expected Results:  
WYSIWYG    You should be able to see the text you type. Not blank.
Browser, not Bugzilla
Component: Bugzilla-General → Layout: Form Controls
Product: Bugzilla → Browser
Version: unspecified → Trunk
oops, reassign to default...
Assignee: justdave → form
QA Contact: matty → tpreston

Comment 3

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021214
I see this problem also.  Text entry is echoed properly using MSIE 6.0
Suggest STATUS: NEW

Comment 4

16 years ago
I see this in 2002121409 OS/2 trunk, but suspect bad page code due to whose page
it is, so not marking new.
OS: Windows XP → All
Created attachment 109370 [details]
Reduced testcase

Here's a reduced testcase. Absolutely positioned <span> seems to cause the
problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: Blank text when typing into the quote box → Absolutely positioned span makes text in <input> disappear

Comment 7

16 years ago
it's the "z-index=-1" caused the problem. 
That is weird.
Assignee: form → roc+moz
Priority: -- → P2

*** This bug has been marked as a duplicate of 182107 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.