"new folder" control in bookmark manager inputs wrong symbols in win-1251 codepage (cyrillic)

VERIFIED DUPLICATE of bug 191184

Status

()

Core
Internationalization
P2
minor
VERIFIED DUPLICATE of bug 191184
16 years ago
16 years ago

People

(Reporter: Shamil Kerimov, Assigned: Frank Tang)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Open Bookmarks Manager, click New Folder, then type something in Cyrillic locale
(win-1251 codepage). It will look like keymap went mad, and input roman capital
symbols, numbers and other letters, instead of cyrillic symbols.

Reproducible: Always

Steps to Reproduce:
1. Make sure you have Cyrillic locale installed and working
2. Open Bookmark manager
3. Click "New Folder"
4. Switch to Cyrillic locale and type something.
Actual Results:  
I had to paste the folder name from clipboard
far away from "string"
Assignee: jaggernaut → smontagu
Component: String → Internationalization
QA Contact: scc → ylong
To ftang
Assignee: smontagu → ftang
(Assignee)

Comment 3

16 years ago
I can see this problem. but only in the bookmark manager "new folder" dialgobox
in my 20021121 build. 
Can see this on other keyboard such as Thai or Armenian too.
I guess the code is from the following places. 
I got similar problem in messanger "File:New Folder" and "New Account"
I guess it is someting to do with Model dialogbox. 

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
this seems a bug we should fix. 
Blocks: 157673
(Assignee)

Comment 5

16 years ago
estimate 5-7 days of debugging and fixing. Looks like nasty issue with model
dialog and unicode version on WinXP / 2000
Keywords: intl
Priority: -- → P2
(Assignee)

Comment 6

16 years ago
can some one check is this a regressoin from 7.0 or 7.01 ?
Duping all these bugs to the one I have a patch in.

*** This bug has been marked as a duplicate of 191184 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Mark as verified per previous comment.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.