SOCKS5: does not work w/ IP address

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Chris Carlin, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checkwin checklinux)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

I noticed in Mail/News that it wasn't working with the socks5 proxy I was
specifying. Since I own the proxy too I could see that Mozilla wasn't even
trying to connect to the proxy at all. I tried all kinds of things like
restarting Mozilla and blanking out all of the http and ftp proxies. When I did
that I noticed that Mozilla wouldn't try to use the socks proxy for the web
either. Eventually I discovered that while all of the other proxies would work
by a specified ip address, the socks proxy wanted a hostname. Go figure.

Reproducible: Always

Steps to Reproduce:
1. Enter http and socks proxy addresses by ip address in the preferences place
2. Try to access the web and a mail (I'm on IMAP) account. The web will work,
the mail will not.
3. Blank out all of the http proxy specifications, leaving only the socks5.
4. Try to access web and mail again. Neither will work.
5. Specify a resolvable hostname for the socks proxy.
6. Try to access web and mail. Both will work.
7. Specify web proxy addresses again.
8. Everything will finally be working as expected.
Actual Results:  
The socks proxy will not be contacted for anything as long as it is specified by
ip address.

Expected Results:  
The socks proxy will be contacted as needed even when specified as an ip
address. Either that or at least have the other proxies require hostnames too...

Ummm, socks 5 going to a dante server.
I was watching the debug on the server and seeing no connections though when I
ran AIM through it from the same computer it worked without a hitch.

Comment 1

16 years ago
I can say that I never got around to testing the IP address in that pref.

Do you want a workaround?
QA Contact: benc → socksqa
Summary: Something not working right with socks name resolution → SOCKS5: does not work w/ IP address
(Reporter)

Comment 2

16 years ago
My workaround is to just use a resolvable hostname in the field.

Works fine for me, but I don't know what I'd do if I couldn't use a hostname.

Comment 3

16 years ago
(to save the next person the problem... /etc/hosts)

Comment 4

16 years ago
+clean-report, -> NEW

Mozilla 1.3a, Win98.

I followed the steps, and found that I would get a "connection refused" error to
the destination.

Oddly, netstat did show a connection to the IP:port of the proxy config in
SYN_SENT, which suggests that there is not an addressing problem, but a
connection establishment problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: clean-report

Comment 5

16 years ago
bradley, darin, any suggestions?
(Assignee)

Comment 6

16 years ago
can anyone provide a packet trace on the SOCKS port?
There was a patch to have socks do dns lookups, and that did ugly things base
don 'are we an ip yet'. Did that patch go in? If so, maybe it got confused..

Comment 8

16 years ago
over to darin.
Assignee: dougt → darin

Comment 9

15 years ago
I could not reproduce the bugs with recent builds on OS X nor Windows 2000. 
Perhaps it's WFM now?
(Assignee)

Comment 10

15 years ago
marking WORKSFORME.  reporter: please reopen this bug if the problem occurs again. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 11

14 years ago
V/WFM Mac OS X 10.3, Mozilla 1.7 branch, 2004-05-13
Status: RESOLVED → VERIFIED
Keywords: clean-report

Updated

14 years ago
Whiteboard: checkwin checklinux
You need to log in before you can comment on or make changes to this bug.